summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-02-20 14:15:24 +0000
committerHans de Graaff <graaff@gentoo.org>2011-02-20 14:15:24 +0000
commit1c0dc6207e30209f03163699a1b23c31aac175e3 (patch)
treef35d09e13a896b74b1da9d2d54c936a0ccca9e28
parentVersion bump (diff)
downloadgentoo-2-1c0dc6207e30209f03163699a1b23c31aac175e3.tar.gz
gentoo-2-1c0dc6207e30209f03163699a1b23c31aac175e3.tar.bz2
gentoo-2-1c0dc6207e30209f03163699a1b23c31aac175e3.zip
Version bump.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
-rw-r--r--dev-ruby/async_sinatra/ChangeLog8
-rw-r--r--dev-ruby/async_sinatra/async_sinatra-0.4.0.ebuild45
-rw-r--r--dev-ruby/async_sinatra/files/async_sinatra-0.4.0-rack.patch22
3 files changed, 74 insertions, 1 deletions
diff --git a/dev-ruby/async_sinatra/ChangeLog b/dev-ruby/async_sinatra/ChangeLog
index 34a2468fa5a6..6bf3153d0e88 100644
--- a/dev-ruby/async_sinatra/ChangeLog
+++ b/dev-ruby/async_sinatra/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/async_sinatra
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/async_sinatra/ChangeLog,v 1.3 2011/01/02 08:36:17 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/async_sinatra/ChangeLog,v 1.4 2011/02/20 14:15:24 graaff Exp $
+
+*async_sinatra-0.4.0 (20 Feb 2011)
+
+ 20 Feb 2011; Hans de Graaff <graaff@gentoo.org>
+ +async_sinatra-0.4.0.ebuild, +files/async_sinatra-0.4.0-rack.patch:
+ Version bump.
*async_sinatra-0.3.0 (02 Jan 2011)
diff --git a/dev-ruby/async_sinatra/async_sinatra-0.4.0.ebuild b/dev-ruby/async_sinatra/async_sinatra-0.4.0.ebuild
new file mode 100644
index 000000000000..ea353de8ef16
--- /dev/null
+++ b/dev-ruby/async_sinatra/async_sinatra-0.4.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/async_sinatra/async_sinatra-0.4.0.ebuild,v 1.1 2011/02/20 14:15:24 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_DOCDIR="html"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.rdoc"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+# the documentation-building requires the gemspec file that is not
+# packaged, this is very unfortunate for us, but the doc does not
+# really tell us much so we're not going out of our way to get this
+# from GIT. Upstream bug filed.
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Asynchronous response API for Sinatra and Thin"
+HOMEPAGE="http://libraggi.rubyforge.org/async_sinatra"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RUBY_PATCHES=( "${FILESDIR}/${P}-rack.patch" )
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 dev-ruby/eventmachine )"
+
+ruby_add_rdepend '>=dev-ruby/sinatra-1.0
+ >=www-servers/thin-1.2.0'
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/test_async.rb || die "Tests failed."
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}/
+ doins -r examples || die "Failed to install examples"
+}
diff --git a/dev-ruby/async_sinatra/files/async_sinatra-0.4.0-rack.patch b/dev-ruby/async_sinatra/files/async_sinatra-0.4.0-rack.patch
new file mode 100644
index 000000000000..2785db63a146
--- /dev/null
+++ b/dev-ruby/async_sinatra/files/async_sinatra-0.4.0-rack.patch
@@ -0,0 +1,22 @@
+Fix expectation for newer versions of rack. See
+https://github.com/raggi/async_sinatra/issues/#issue/10
+
+--- test/test_async.rb.~1~ 2011-02-20 15:05:47.480108199 +0100
++++ test/test_async.rb 2011-02-20 15:09:38.494594250 +0100
+@@ -96,8 +96,7 @@
+
+ def assert_redirect(path)
+ r = last_request.env
+- uri = r['rack.url_scheme'] + '://' + r['SERVER_NAME'] + path
+- assert_equal uri, last_response.location
++ assert_equal path, last_response.location
+ end
+
+ def test_basic_async_get
+@@ -194,4 +193,4 @@
+ assert_equal 302, last_response.status
+ assert_redirect '/'
+ end
+-end
+\ No newline at end of file
++end