summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-03-10 10:19:53 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-03-10 10:19:53 +0000
commit1b473c29c2a50d311bfa9c9bbed998692cb927eb (patch)
treec26c1fe96ec71902184272a5865cf3a766382c37
parentNLS fixes submitted by seemant@rocketmail.com (Seemant Kulleen) (diff)
downloadgentoo-2-1b473c29c2a50d311bfa9c9bbed998692cb927eb.tar.gz
gentoo-2-1b473c29c2a50d311bfa9c9bbed998692cb927eb.tar.bz2
gentoo-2-1b473c29c2a50d311bfa9c9bbed998692cb927eb.zip
NLS fixes submitted by seemant@rocketmail.com (Seemant Kulleen)
-rw-r--r--x11-libs/gtk+/ChangeLog16
-rw-r--r--x11-libs/gtk+/files/digest-gtk+-1.2.10-r51
-rw-r--r--x11-libs/gtk+/gtk+-1.2.10-r5.ebuild81
3 files changed, 89 insertions, 9 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index c158d474166f..1444becd936f 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,13 +1,11 @@
# ChangeLog for x11-libs/gtk+
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.1 2002/02/01 21:53:38 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.2 2002/03/10 10:19:52 blocke Exp $
+
+*gtk+-1.2.10-r5 (10 Mar 2002)
+
+ 10 Mar 2002; Bruce A. Locke <blocke@shivan.org> gtk+-1.2.10-r5.ebuild :
+
+ NLS fixes submitted by seemant@rocketmail.com (Seemant Kulleen)
-*gtk+-1.2.10-r4 (1 Feb 2002)
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
diff --git a/x11-libs/gtk+/files/digest-gtk+-1.2.10-r5 b/x11-libs/gtk+/files/digest-gtk+-1.2.10-r5
new file mode 100644
index 000000000000..5116729f5974
--- /dev/null
+++ b/x11-libs/gtk+/files/digest-gtk+-1.2.10-r5
@@ -0,0 +1 @@
+MD5 4d5cb2fc7fb7830e4af9747a36bfce20 gtk+-1.2.10.tar.gz 2868322
diff --git a/x11-libs/gtk+/gtk+-1.2.10-r5.ebuild b/x11-libs/gtk+/gtk+-1.2.10-r5.ebuild
new file mode 100644
index 000000000000..9eb359264a7b
--- /dev/null
+++ b/x11-libs/gtk+/gtk+-1.2.10-r5.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-1.2.10-r5.ebuild,v 1.1 2002/03/10 10:19:53 blocke Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="The GIMP Toolkit"
+HOMEPAGE="http://www.gtk.org/"
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/v1.2/${A}
+ ftp://ftp.gnome.org/pub/GNOME/stable/sources/gtk+/${A}
+ http://ftp.gnome.org/pub/GNOME/stable/sources/gtk+/${A}"
+
+DEPEND="virtual/glibc virtual/x11
+ >=dev-libs/glib-1.2.10
+ nls? ( sys-devel/gettext
+ dev-util/intltool )"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ patch -p0 < ${FILESDIR}/gtk-1.2.10.patch || die
+}
+
+src_compile() {
+
+ local myconf
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ if [ "${DEBUG}" ]
+ then
+ myconf="${myconf} --enable-debug=yes"
+ else
+ myconf="${myconf} --enable-debug=no"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/X11 \
+ --with-xinput=xfree \
+ --with-x \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+
+ make install DESTDIR=${D} || die
+
+ preplib /usr
+
+ dodoc AUTHORS COPYING ChangeLog* HACKING
+ dodoc NEWS* README* TODO
+ docinto docs
+ cd docs
+ dodoc *.txt *.gif text/*
+ cd html
+ docinto html
+ dodoc *.html *.gif
+
+ #install nice, clean-looking gtk+ style
+ insinto /usr/share/themes/Gentoo/gtk
+ doins ${FILESDIR}/gtkrc
+}
+
+pkg_postinst() {
+
+ echo
+ echo "**********************************************************************"
+ echo "* Older versions added /etc/X11/gtk/gtkrc which changed settings for *"
+ echo "* all themes it seems. Please remove it manually as it will not due *"
+ echo "* to /env protection. *"
+ echo "* *"
+ echo "* NB: The old gtkrc is available through the new Gentoo gtk theme. *"
+ echo "**********************************************************************"
+ echo
+}