summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-10-03 12:40:26 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-10-03 12:40:26 +0000
commit1385af6bc6600d0e3e933001e4105affff1e94e7 (patch)
tree4b10b5d252fb9cf71550a8a2bd0de8f32ad64d64
parentversion bump (diff)
downloadgentoo-2-1385af6bc6600d0e3e933001e4105affff1e94e7.tar.gz
gentoo-2-1385af6bc6600d0e3e933001e4105affff1e94e7.tar.bz2
gentoo-2-1385af6bc6600d0e3e933001e4105affff1e94e7.zip
version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
-rw-r--r--dev-lang/elixir/ChangeLog7
-rw-r--r--dev-lang/elixir/elixir-0.10.3.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-lang/elixir/ChangeLog b/dev-lang/elixir/ChangeLog
index 330462616e41..4da3c6778096 100644
--- a/dev-lang/elixir/ChangeLog
+++ b/dev-lang/elixir/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/elixir
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/elixir/ChangeLog,v 1.5 2013/09/03 22:55:04 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/elixir/ChangeLog,v 1.6 2013/10/03 12:40:26 hasufell Exp $
+
+*elixir-0.10.3 (03 Oct 2013)
+
+ 03 Oct 2013; Julian Ospald <hasufell@gentoo.org> +elixir-0.10.3.ebuild:
+ version bump
*elixir-0.10.2 (03 Sep 2013)
diff --git a/dev-lang/elixir/elixir-0.10.3.ebuild b/dev-lang/elixir/elixir-0.10.3.ebuild
new file mode 100644
index 000000000000..5dc8f05c3afe
--- /dev/null
+++ b/dev-lang/elixir/elixir-0.10.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/elixir/elixir-0.10.3.ebuild,v 1.1 2013/10/03 12:40:26 hasufell Exp $
+
+EAPI=5
+
+inherit multilib
+
+DESCRIPTION="Elixir programming language"
+HOMEPAGE="http://elixir-lang.org"
+SRC_URI="https://github.com/elixir-lang/elixir/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 ErlPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/erlang-16"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake Q=""
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="$(get_libdir)" PREFIX="/usr" install
+ dodoc README.md CHANGELOG.md CONTRIBUTING.md
+}