summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2015-04-12 22:17:48 +0000
committerAlex Brandt <alunduil@gentoo.org>2015-04-12 22:17:48 +0000
commit1172d17ea3f1cea640e0adf83fc11411774cadd5 (patch)
tree1e0d36b09401eb5872183a62a3bb27cbedba0242
parentadd version 1.8.3 (diff)
downloadgentoo-2-1172d17ea3f1cea640e0adf83fc11411774cadd5.tar.gz
gentoo-2-1172d17ea3f1cea640e0adf83fc11411774cadd5.tar.bz2
gentoo-2-1172d17ea3f1cea640e0adf83fc11411774cadd5.zip
remove version 1.8.1
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 11A8217C!)
-rw-r--r--dev-python/pyhamcrest/ChangeLog5
-rw-r--r--dev-python/pyhamcrest/pyhamcrest-1.8.1.ebuild49
2 files changed, 4 insertions, 50 deletions
diff --git a/dev-python/pyhamcrest/ChangeLog b/dev-python/pyhamcrest/ChangeLog
index eadc44cd9b33..f7de6df15a84 100644
--- a/dev-python/pyhamcrest/ChangeLog
+++ b/dev-python/pyhamcrest/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/pyhamcrest
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyhamcrest/ChangeLog,v 1.5 2015/04/12 22:16:49 alunduil Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyhamcrest/ChangeLog,v 1.6 2015/04/12 22:17:48 alunduil Exp $
+
+ 12 Apr 2015; Alex Brandt <alunduil@gentoo.org> -pyhamcrest-1.8.1.ebuild:
+ remove version 1.8.1
*pyhamcrest-1.8.3 (12 Apr 2015)
diff --git a/dev-python/pyhamcrest/pyhamcrest-1.8.1.ebuild b/dev-python/pyhamcrest/pyhamcrest-1.8.1.ebuild
deleted file mode 100644
index 176a703c2284..000000000000
--- a/dev-python/pyhamcrest/pyhamcrest-1.8.1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyhamcrest/pyhamcrest-1.8.1.ebuild,v 1.2 2014/10/11 21:14:04 alunduil Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_3 python3_4 pypy )
-
-inherit distutils-r1
-
-MY_PN="PyHamcrest"
-
-DESCRIPTION="Hamcrest framework for matcher objects"
-HOMEPAGE="https://github.com/hamcrest/PyHamcrest"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="doc examples numpy test"
-
-CDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'numpy? ( dev-python/numpy[${PYTHON_USEDEP}] )' 'python*')
-"
-DEPEND="
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- ${CDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="${CDEPEND}"
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- py.test -v || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/_build/html/. )
- use examples && local EXAMPLES=( examples/. )
-
- distutils-r1_python_install_all
-}