summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-01-27 16:29:04 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-01-27 16:29:04 +0000
commit10a81703d6a4250e0c6be3c9eabc05c8d79c1443 (patch)
treefc3b361d21dc8aa0c061541606f0ccc3d50e25d4
parentBump shiny new KDE 4.2.0 (diff)
downloadgentoo-2-10a81703d6a4250e0c6be3c9eabc05c8d79c1443.tar.gz
gentoo-2-10a81703d6a4250e0c6be3c9eabc05c8d79c1443.tar.bz2
gentoo-2-10a81703d6a4250e0c6be3c9eabc05c8d79c1443.zip
Bump shiny new KDE 4.2.0
(Portage version: 2.2_rc23/cvs/Linux x86_64)
-rw-r--r--kde-base/dolphin/ChangeLog7
-rw-r--r--kde-base/dolphin/dolphin-4.2.0.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/kde-base/dolphin/ChangeLog b/kde-base/dolphin/ChangeLog
index 0d7170099b22..809bebe94b63 100644
--- a/kde-base/dolphin/ChangeLog
+++ b/kde-base/dolphin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/dolphin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.18 2009/01/14 13:56:26 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.19 2009/01/27 16:29:04 alexxy Exp $
+
+*dolphin-4.2.0 (27 Jan 2009)
+
+ 27 Jan 2009; Alexey Shvetsov <alexxy@gentoo.org> +dolphin-4.2.0.ebuild:
+ Bump KDE-4.2.0
14 Jan 2009; Alexey Shvetsov <alexxy@gentoo.org> -dolphin-4.1.2.ebuild,
-dolphin-4.1.3.ebuild:
diff --git a/kde-base/dolphin/dolphin-4.2.0.ebuild b/kde-base/dolphin/dolphin-4.2.0.ebuild
new file mode 100644
index 000000000000..0b86c5dca9f9
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.2.0.ebuild,v 1.1 2009/01/27 16:29:04 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdebase"
+KMMODULE="apps/${PN}"
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug htmlhandbook +semantic-desktop"
+
+DEPEND="
+ >=kde-base/libkonq-${PV}:${SLOT}
+ kde-base/kdelibs:${SLOT}[semantic-desktop=]
+ semantic-desktop? ( >=kde-base/nepomuk-${PV}:${SLOT} )"
+RDEPEND="${DEPEND}"
+
+KMEXTRA="apps/doc/${PN}"
+KMLOADLIBS="libkonq"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)"
+ kde4-meta_src_configure
+}