summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-12-24 12:41:09 +0000
committerPacho Ramos <pacho@gentoo.org>2013-12-24 12:41:09 +0000
commit0dbfa9af7fe61a5bd7273037633d054636b0069c (patch)
treed9d8371dc54448222a3ff18937a92dcb824b22a6
parentStable for x86, wrt bug #490500 (diff)
downloadgentoo-2-0dbfa9af7fe61a5bd7273037633d054636b0069c.tar.gz
gentoo-2-0dbfa9af7fe61a5bd7273037633d054636b0069c.tar.bz2
gentoo-2-0dbfa9af7fe61a5bd7273037633d054636b0069c.zip
Fix double clicking an item or hitting enter after selecting an item (#493332 by Kai Wustermann), drop old.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
-rw-r--r--gnome-extra/zenity/ChangeLog10
-rw-r--r--gnome-extra/zenity/files/zenity-3.8.0-double-click.patch26
-rw-r--r--gnome-extra/zenity/zenity-3.8.0-r1.ebuild (renamed from gnome-extra/zenity/zenity-3.6.0.ebuild)36
3 files changed, 56 insertions, 16 deletions
diff --git a/gnome-extra/zenity/ChangeLog b/gnome-extra/zenity/ChangeLog
index db5a8c52e5ab..e896d14579d0 100644
--- a/gnome-extra/zenity/ChangeLog
+++ b/gnome-extra/zenity/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for gnome-extra/zenity
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/zenity/ChangeLog,v 1.213 2013/12/08 19:02:58 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/zenity/ChangeLog,v 1.214 2013/12/24 12:41:09 pacho Exp $
+
+*zenity-3.8.0-r1 (24 Dec 2013)
+
+ 24 Dec 2013; Pacho Ramos <pacho@gentoo.org>
+ +files/zenity-3.8.0-double-click.patch, +zenity-3.8.0-r1.ebuild,
+ -zenity-3.6.0.ebuild:
+ Fix double clicking an item or hitting enter after selecting an item (#493332
+ by Kai Wustermann), drop old.
08 Dec 2013; Pacho Ramos <pacho@gentoo.org> zenity-3.8.0.ebuild:
x86 stable, bug #478252
diff --git a/gnome-extra/zenity/files/zenity-3.8.0-double-click.patch b/gnome-extra/zenity/files/zenity-3.8.0-double-click.patch
new file mode 100644
index 000000000000..53491d03a3aa
--- /dev/null
+++ b/gnome-extra/zenity/files/zenity-3.8.0-double-click.patch
@@ -0,0 +1,26 @@
+From 7c234ed9b71d5f009abff509ef2bf576f61a0cbb Mon Sep 17 00:00:00 2001
+From: Arx Cruz <arxcruz@gnome.org>
+Date: Thu, 23 May 2013 19:27:58 +0000
+Subject: Bug 698683 - Double clicking an item or hitting enter after selecting an item
+
+returns it twice
+---
+diff --git a/src/tree.c b/src/tree.c
+index cf90239..031765e 100644
+--- a/src/tree.c
++++ b/src/tree.c
+@@ -710,12 +710,6 @@ zenity_tree_row_activated (GtkTreeView *tree_view, GtkTreePath *tree_path,
+ GtkTreeViewColumn *tree_col, gpointer data)
+ {
+ ZenityData *zen_data = data;
+- GtkTreeSelection *selection;
+-
+- selection = gtk_tree_view_get_selection (GTK_TREE_VIEW (tree_view));
+- gtk_tree_selection_selected_foreach (selection,
+- (GtkTreeSelectionForeachFunc) zenity_tree_dialog_get_selected,
+- GTK_TREE_VIEW (tree_view));
+
+ zenity_tree_dialog_output ();
+ zen_data->exit_code = zenity_util_return_exit_code (ZENITY_OK);
+--
+cgit v0.9.2
diff --git a/gnome-extra/zenity/zenity-3.6.0.ebuild b/gnome-extra/zenity/zenity-3.8.0-r1.ebuild
index 2ef872049923..98cfb4be8427 100644
--- a/gnome-extra/zenity/zenity-3.6.0.ebuild
+++ b/gnome-extra/zenity/zenity-3.8.0-r1.ebuild
@@ -1,46 +1,52 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/zenity/zenity-3.6.0.ebuild,v 1.1 2012/12/24 00:35:19 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/zenity/zenity-3.8.0-r1.ebuild,v 1.1 2013/12/24 12:41:09 pacho Exp $
EAPI="5"
GCONF_DEBUG="yes"
-GNOME2_LA_PUNT="yes"
-inherit gnome2
+inherit eutils gnome2
DESCRIPTION="Tool to display dialogs from the commandline and shell scripts"
-HOMEPAGE="http://live.gnome.org/Zenity"
+HOMEPAGE="https://wiki.gnome.org/action/show/Projects/Zenity"
LICENSE="LGPL-2+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
IUSE="libnotify test +webkit"
-RDEPEND=">=dev-libs/glib-2.8:2
+RDEPEND="
+ >=dev-libs/glib-2.8:2
x11-libs/gdk-pixbuf:2
>=x11-libs/gtk+-3:3
x11-libs/libX11
x11-libs/pango
libnotify? ( >=x11-libs/libnotify-0.6.1:= )
- webkit? ( >=net-libs/webkit-gtk-1.4.0:3 )"
-
+ webkit? ( >=net-libs/webkit-gtk-1.4.0:3 )
+"
DEPEND="${RDEPEND}
>=dev-util/intltool-0.40
>=sys-devel/gettext-0.14
virtual/pkgconfig
- test? ( app-text/yelp-tools )"
+ test? ( app-text/yelp-tools )
+"
# eautoreconf needs:
# >=gnome-base/gnome-common-2.12
+src_prepare() {
+ # Fix double clicking an item or hitting enter after selecting an item (from 'master')
+ epatch "${FILESDIR}/${PN}-3.8.0-double-click.patch"
+ gnome2_src_prepare
+}
+
src_configure() {
DOCS="AUTHORS ChangeLog HACKING NEWS README THANKS TODO"
- G2CONF="${G2CONF}
- $(use_enable libnotify)
- $(use_enable webkit webkitgtk)
- PERL=$(type -P false)
- ITSTOOL=$(type -P true)"
- gnome2_src_configure
+ gnome2_src_configure \
+ $(use_enable libnotify) \
+ $(use_enable webkit webkitgtk) \
+ PERL=$(type -P false) \
+ ITSTOOL=$(type -P true)
}
src_install() {