summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-08-11 08:38:03 +0000
committerHans de Graaff <graaff@gentoo.org>2012-08-11 08:38:03 +0000
commit0d39a185332a5a1b0ef9d19ea7f6c716d86a911d (patch)
tree8aff6415c947557a2be1630c7d34746407447589
parentVersion bumps for security bug 430718. (diff)
downloadgentoo-2-0d39a185332a5a1b0ef9d19ea7f6c716d86a911d.tar.gz
gentoo-2-0d39a185332a5a1b0ef9d19ea7f6c716d86a911d.tar.bz2
gentoo-2-0d39a185332a5a1b0ef9d19ea7f6c716d86a911d.zip
Version bumps for security bug 430718.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
-rw-r--r--dev-ruby/activerecord/ChangeLog9
-rw-r--r--dev-ruby/activerecord/activerecord-3.0.17.ebuild71
-rw-r--r--dev-ruby/activerecord/activerecord-3.1.8.ebuild70
3 files changed, 149 insertions, 1 deletions
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index 4f16c21ab910..16ea7cf8fb24 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.194 2012/08/10 06:44:33 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.195 2012/08/11 08:38:03 graaff Exp $
+
+*activerecord-3.1.8 (11 Aug 2012)
+*activerecord-3.0.17 (11 Aug 2012)
+
+ 11 Aug 2012; Hans de Graaff <graaff@gentoo.org> +activerecord-3.0.17.ebuild,
+ +activerecord-3.1.8.ebuild:
+ Version bumps for security bug 430718.
*activerecord-3.2.8 (10 Aug 2012)
diff --git a/dev-ruby/activerecord/activerecord-3.0.17.ebuild b/dev-ruby/activerecord/activerecord-3.0.17.ebuild
new file mode 100644
index 000000000000..37731544abac
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-3.0.17.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-3.0.17.ebuild,v 1.1 2012/08/11 08:38:03 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18"
+
+# this is not null so that the dependencies will actually be filled
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="mysql postgres sqlite3"
+
+RUBY_S="rails-rails-*/activerecord"
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ ~dev-ruby/activemodel-${PV}
+ >=dev-ruby/arel-2.0.10-r1:2.0
+ >=dev-ruby/tzinfo-0.3.23
+ sqlite3? ( >=dev-ruby/sqlite3-ruby-1.3.3 )
+ mysql? ( dev-ruby/mysql2:0.2 )
+ postgres? ( dev-ruby/pg )"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/bundler
+ ~dev-ruby/actionpack-${PV}
+ >=dev-ruby/sqlite3-ruby-1.3.3
+ >=dev-ruby/mocha-0.10.5
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e '/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|"mysql"\|mysql2\)/d' ../Gemfile || die
+# sed -i -e '/rack-ssl/d' ../railties/railties.gemspec || die
+# sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
+ sed -i -e '/\(system_timer\|horo\|faker\|rbench\|ruby-debug\|pg\)/d' ../Gemfile || die
+
+ # Loosen erubis dependency since this is not slotted.
+ sed -i -e 's/~> 2.6.6/>= 2.6.6/' ../actionpack/actionpack.gemspec || die
+
+ # Loosen mocha version restriction and skip incompatible tests
+ sed -i -e 's/0.10.5/>= 0.10.5/' ../Gemfile || die
+ rm test/cases/autosave_association_test.rb || die
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ ;;
+ *)
+ if use sqlite3; then
+ ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
+ fi
+ ;;
+ esac
+}
diff --git a/dev-ruby/activerecord/activerecord-3.1.8.ebuild b/dev-ruby/activerecord/activerecord-3.1.8.ebuild
new file mode 100644
index 000000000000..6d8f1de2bbd6
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-3.1.8.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-3.1.8.ebuild,v 1.1 2012/08/11 08:38:03 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18"
+
+# this is not null so that the dependencies will actually be filled
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.1"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="mysql postgres sqlite3"
+
+RUBY_S="rails-rails-*/activerecord"
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ ~dev-ruby/activemodel-${PV}
+ >=dev-ruby/arel-2.2.3:2.1
+ >=dev-ruby/tzinfo-0.3.29
+ sqlite3? ( >=dev-ruby/sqlite3-ruby-1.3.4 )
+ mysql? ( >=dev-ruby/mysql2-0.3.6:0.3 )
+ postgres? ( >=dev-ruby/pg-0.11.0 )"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/bundler
+ ~dev-ruby/actionpack-${PV}
+ >=dev-ruby/sqlite3-ruby-1.3.3
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e '/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|"mysql"\|ruby-prof\)/d' ../Gemfile || die
+ sed -i -e '/rack-ssl/d' ../railties/railties.gemspec || die
+ sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
+ sed -i -e "s/, '< 1.3'//" ../activesupport/activesupport.gemspec || die
+
+ # Loosen mocha version restriction and skip incompatible tests
+ sed -i -e 's/0.10.5/>= 0.10.5/' ../Gemfile || die
+ sed -i -e '/test_a_child_marked_for_destruction_should_not_be_destroyed_twice/,/^ end/ s:^:#:' test/cases/autosave_association_test.rb || die
+ sed -i -e '/test_a_parent_marked_for_destruction_should_not_be_destroyed_twice/,/^ end/ s:^:#:' test/cases/autosave_association_test.rb || die
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ ;;
+ *)
+ if use sqlite3; then
+ ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
+ fi
+ ;;
+ esac
+}