summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-01-01 14:07:30 +0000
committerMichał Górny <mgorny@gentoo.org>2013-01-01 14:07:30 +0000
commit0d245221a1477a8caf5a042270d3b0da3ce61cb7 (patch)
tree6781adaf988a74afd3899483907c07e51c6443c0
parentUse virtual/pyparsing. (diff)
downloadgentoo-2-0d245221a1477a8caf5a042270d3b0da3ce61cb7.tar.gz
gentoo-2-0d245221a1477a8caf5a042270d3b0da3ce61cb7.tar.bz2
gentoo-2-0d245221a1477a8caf5a042270d3b0da3ce61cb7.zip
Version bump. Upstream has split pyparsing to a Python 2-compatible 1.* branch and Python 3-compatible 2.* branch.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
-rw-r--r--dev-python/pyparsing/ChangeLog12
-rw-r--r--dev-python/pyparsing/pyparsing-1.5.7.ebuild28
-rw-r--r--dev-python/pyparsing/pyparsing-2.0.0.ebuild29
3 files changed, 67 insertions, 2 deletions
diff --git a/dev-python/pyparsing/ChangeLog b/dev-python/pyparsing/ChangeLog
index 5a11cce2286c..b781af0b3eb3 100644
--- a/dev-python/pyparsing/ChangeLog
+++ b/dev-python/pyparsing/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/pyparsing
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparsing/ChangeLog,v 1.86 2012/12/21 10:15:31 mgorny Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparsing/ChangeLog,v 1.87 2013/01/01 14:07:30 mgorny Exp $
+
+*pyparsing-1.5.7 (01 Jan 2013)
+*pyparsing-2.0.0 (01 Jan 2013)
+
+ 01 Jan 2013; Michał Górny <mgorny@gentoo.org> +pyparsing-1.5.7.ebuild,
+ +pyparsing-2.0.0.ebuild:
+ Version bump. Upstream has split pyparsing to a Python 2-compatible 1.* branch
+ and Python 3-compatible 2.* branch.
*pyparsing-1.5.6-r2 (21 Dec 2012)
diff --git a/dev-python/pyparsing/pyparsing-1.5.7.ebuild b/dev-python/pyparsing/pyparsing-1.5.7.ebuild
new file mode 100644
index 000000000000..c0b081c44a13
--- /dev/null
+++ b/dev-python/pyparsing/pyparsing-1.5.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparsing/pyparsing-1.5.7.ebuild,v 1.1 2013/01/01 14:07:30 mgorny Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy{1_8,1_9} )
+
+inherit distutils-r1
+
+DESCRIPTION="pyparsing is an easy-to-use Python module for text parsing"
+HOMEPAGE="http://pyparsing.wikispaces.com/ http://pypi.python.org/pypi/pyparsing"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="py2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples"
+
+RDEPEND="!dev-python/pyparsing:0"
+
+python_install_all() {
+ local HTML_DOCS=( HowToUsePyparsing.html )
+
+ distutils-r1_python_install_all
+
+ use doc && dodoc docs/*.pdf
+ use examples && dodoc -r examples
+}
diff --git a/dev-python/pyparsing/pyparsing-2.0.0.ebuild b/dev-python/pyparsing/pyparsing-2.0.0.ebuild
new file mode 100644
index 000000000000..cec3b40b37d0
--- /dev/null
+++ b/dev-python/pyparsing/pyparsing-2.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparsing/pyparsing-2.0.0.ebuild,v 1.1 2013/01/01 14:07:30 mgorny Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{3_1,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="pyparsing is an easy-to-use Python module for text parsing"
+HOMEPAGE="http://pyparsing.wikispaces.com/ http://pypi.python.org/pypi/pyparsing"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="py3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples"
+
+RDEPEND="!dev-python/pyparsing:0"
+
+python_install_all() {
+ local HTML_DOCS=( HowToUsePyparsing.html )
+ use doc && HTML_DOCS+=( htmldoc/ )
+
+ distutils-r1_python_install_all
+
+ use doc && dodoc docs/*.pdf
+ use examples && dodoc -r examples
+}