summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2005-04-29 09:39:19 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2005-04-29 09:39:19 +0000
commit032aa1e758683c5651f03e4c89af2d5d19db350f (patch)
tree20218f73f860148c85c68961efc90186aa2a0fa9
parentxfsprogs gcc4 fix (diff)
downloadgentoo-2-032aa1e758683c5651f03e4c89af2d5d19db350f.tar.gz
gentoo-2-032aa1e758683c5651f03e4c89af2d5d19db350f.tar.bz2
gentoo-2-032aa1e758683c5651f03e4c89af2d5d19db350f.zip
threading autodisable with dlz and mysql
(Portage version: 2.0.51.20-r5)
-rw-r--r--net-dns/bind/ChangeLog8
-rw-r--r--net-dns/bind/Manifest4
-rw-r--r--net-dns/bind/bind-9.2.5-r4.ebuild (renamed from net-dns/bind/bind-9.2.5-r3.ebuild)38
-rw-r--r--net-dns/bind/files/digest-bind-9.2.5-r4 (renamed from net-dns/bind/files/digest-bind-9.2.5-r3)0
4 files changed, 31 insertions, 19 deletions
diff --git a/net-dns/bind/ChangeLog b/net-dns/bind/ChangeLog
index 3cb90f00d6fb..5d9f029e7b43 100644
--- a/net-dns/bind/ChangeLog
+++ b/net-dns/bind/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dns/bind
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/ChangeLog,v 1.71 2005/04/26 09:17:52 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/ChangeLog,v 1.72 2005/04/29 09:39:19 voxus Exp $
+
+*bind-9.2.5-r4 (29 Apr 2005)
+
+ 29 Apr 2005; Konstantin Arkhipov <voxus@gentoo.org> -bind-9.2.5-r3.ebuild,
+ +bind-9.2.5-r4.ebuild:
+ Now threading automatically disables when DLZ and MySQL is requested.
*bind-9.2.5-r3 (26 Apr 2005)
diff --git a/net-dns/bind/Manifest b/net-dns/bind/Manifest
index 9f67c8ebca1c..e182f81114e1 100644
--- a/net-dns/bind/Manifest
+++ b/net-dns/bind/Manifest
@@ -1,13 +1,13 @@
MD5 23c809afe06852c286f137645287abb4 bind-9.2.2-r3.ebuild 5708
MD5 2bf2f6ce206ebeb1d8d2f1e8bca56ae4 bind-9.2.5.ebuild 7433
-MD5 060b5517a3f1fb160509ce9bc4883420 bind-9.2.5-r3.ebuild 8005
MD5 64fc49b753eba3d48561cc05d9d284a5 bind-9.3.1-r1.ebuild 6236
MD5 127895edb467aac4b701c125a64f82e0 ChangeLog 11661
MD5 bf7284c3e31bd3292a01fa046b3220bb metadata.xml 352
+MD5 a6bfb9ddddac8e5e3e76bb8380c2722d bind-9.2.5-r4.ebuild 8165
MD5 51197afe8da37b1b453456de90ca4f25 files/127 227
MD5 75d14cac80e71b4ac0662775064c06e2 files/bind-9.2.5-dlz-mysql.patch 11296
MD5 309110e09d923344a34a803f8906fae3 files/digest-bind-9.2.2-r3 121
-MD5 d47c8a742a2645377ba4d783907700dd files/digest-bind-9.2.5-r3 127
+MD5 d47c8a742a2645377ba4d783907700dd files/digest-bind-9.2.5-r4 127
MD5 a8ffc671392ffacafb5c49ffc1c6a4c6 files/named.rc6-pid_fix 488
MD5 c46a805da6650356db77b023d4d042d8 files/digest-bind-9.3.1-r1 63
MD5 4346332cc9681502a3aedfd0a7a1ac41 files/bind-9.2.5-berkdb_fix.patch 537
diff --git a/net-dns/bind/bind-9.2.5-r3.ebuild b/net-dns/bind/bind-9.2.5-r4.ebuild
index c0f17843da82..54fe4a816002 100644
--- a/net-dns/bind/bind-9.2.5-r3.ebuild
+++ b/net-dns/bind/bind-9.2.5-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.2.5-r3.ebuild,v 1.1 2005/04/26 09:17:52 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.2.5-r4.ebuild,v 1.1 2005/04/29 09:39:19 voxus Exp $
inherit eutils libtool
@@ -89,7 +89,27 @@ src_compile() {
use odbc && myconf="${myconf} --with-dlz-odbc"
}
- use threads && myconf="${myconf} --enable-linux-caps --enable-threads"
+ if use threads; then
+ if use dlz && use mysql; then
+ echo
+ ewarn ""
+ einfo "MySQL uses thread local storage in its C api. Thus MySQL"
+ einfo "requires that each thread of an application execute a MySQL"
+ einfo "\"thread initialization\" to setup the thread local storage."
+ einfo "This is impossible to do safely while staying within the DLZ"
+ einfo "driver API. This is a limitation caused by MySQL, and not the"
+ einfo "DLZ API."
+ ewarn "Because of this BIND MUST only run with a single thread when"
+ ewarn "using the MySQL driver."
+ echo
+ myconf="${myconf} --disable-threads"
+ einfo "Threading support disabled"
+ epause 10
+ else
+ myconf="${myconf} --enable-linux-caps --enable-threads"
+ einfo "Threading support enabled"
+ fi
+ fi
econf \
--sysconfdir=/etc/bind \
@@ -190,20 +210,6 @@ pkg_postinst() {
einfo " zone "com" IN { type delegation-only; };"
einfo " zone "net" IN { type delegation-only; };"
- if use dlz && use mysql; then
- echo
- ewarn ""
- einfo "MySQL uses thread local storage in its C api. Thus MySQL"
- einfo "requires that each thread of an application execute a MySQL"
- einfo "\"thread initialization\" to setup the thread local storage."
- einfo "This is impossible to do safely while staying within the DLZ"
- einfo "driver API. This is a limitation caused by MySQL, and not the"
- einfo "DLZ API."
- ewarn "Because of this BIND MUST only run with a single thread when"
- ewarn "using the MySQL driver."
- echo
- fi
-
echo
ewarn "BIND >=9.2.5 makes the priority argument to MX records mandatory"
ewarn "when it was previously optional. If the priority is missing, BIND"
diff --git a/net-dns/bind/files/digest-bind-9.2.5-r3 b/net-dns/bind/files/digest-bind-9.2.5-r4
index 917f82e7d0d6..917f82e7d0d6 100644
--- a/net-dns/bind/files/digest-bind-9.2.5-r3
+++ b/net-dns/bind/files/digest-bind-9.2.5-r4