summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSardem FF7 <sardemff7.pub@gmail.com>2011-02-10 11:55:13 +0100
committerSardem FF7 <sardemff7.pub@gmail.com>2011-02-10 11:55:13 +0100
commit212100791ea01dfee59342164c63ed959f5fa88c (patch)
treeb0eeda09de8a07777b3aec3c880ac8ebe2efd4c5
parentpurple-presence: Add nls (diff)
downloadsardemff7-212100791ea01dfee59342164c63ed959f5fa88c.tar.gz
sardemff7-212100791ea01dfee59342164c63ed959f5fa88c.tar.bz2
sardemff7-212100791ea01dfee59342164c63ed959f5fa88c.zip
xulrunner: fixed upstream
-rw-r--r--net-libs/xulrunner/Manifest2
-rw-r--r--net-libs/xulrunner/files/libnotify-0.7-fix.patch30
-rw-r--r--net-libs/xulrunner/xulrunner-9999.ebuild7
3 files changed, 3 insertions, 36 deletions
diff --git a/net-libs/xulrunner/Manifest b/net-libs/xulrunner/Manifest
index 0404070..cdf9d27 100644
--- a/net-libs/xulrunner/Manifest
+++ b/net-libs/xulrunner/Manifest
@@ -1,4 +1,4 @@
AUX default-prefs.js 709 RMD160 a4d062f75c17552545267ec3fe2f6b54073dafbd SHA1 580128e9edf8021fdbbca2c91abf63cb83bab2c7 SHA256 e6850b0a22f7d3889b49ec4a79a3c4d3d077edd98c8f0ffdc26e30bc70bb4b09
AUX gentoo-specific.patch 2957 RMD160 684dc2176769a56c2b1c206b59f999cd44d99c45 SHA1 35ff8e325e45b5384a404a4f99b12fdba9d5e0f3 SHA256 23d981e48a5308dd11ce2fc831071d138d54717bff9cb546dfc5467b0f4204c7
AUX libnotify-0.7-fix.patch 1209 RMD160 07615cde8fb0dbd9876635d0b437943df3f4879c SHA1 16caf17a571b4ede370fc20ffffc87179afd3cd3 SHA256 80dbd0906b45cd42b0fda0ec6fa48daf04cb5f85a14e164287565ffa4e486642
-EBUILD xulrunner-9999.ebuild 5714 RMD160 1a24c3b87bfb47f7acabd4fa5fb47363e480871c SHA1 e70048e06c014217dac5ac9f4eda8229edb0b166 SHA256 7badc1b3155e53c8592126a17d7702800b96c8b1a49d1ea164e20bf8be8f4087
+EBUILD xulrunner-9999.ebuild 5639 RMD160 4a24b4fa53551cf44ffa4931837923dd49dda2e5 SHA1 bf7a5e6f4947a0b6c7e00b83fd2121541767f1b4 SHA256 19c98a060fd3aefce7514369c7c64bd0c3fc28f65c56f8824fde4a351943fdfe
diff --git a/net-libs/xulrunner/files/libnotify-0.7-fix.patch b/net-libs/xulrunner/files/libnotify-0.7-fix.patch
deleted file mode 100644
index 2464cdf..0000000
--- a/net-libs/xulrunner/files/libnotify-0.7-fix.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff -r 97d9cf2225d6 configure.in
---- a/configure.in Tue Dec 21 15:16:59 2010 +0100
-+++ b/configure.in Tue Dec 21 18:39:39 2010 +0100
-@@ -5669,6 +5669,10 @@
- if test "$MOZ_ENABLE_LIBNOTIFY"
- then
- AC_DEFINE(MOZ_ENABLE_LIBNOTIFY)
-+ PKG_CHECK_MODULES(LIBNOTIFY_07, [libnotify >= 0.7], [have_libnotify_07=yes],[have_libnotify_07=no])
-+ if test x"$have_libnotify_07" = "xno"; then
-+ AC_DEFINE(HAVE_LIBNOTIFY_BEFORE_07, 1, [Define if you have libnotify 0.7 or later])
-+ fi
- fi
- fi
-
-diff -r 97d9cf2225d6 toolkit/system/gnome/nsAlertsIconListener.cpp
---- a/toolkit/system/gnome/nsAlertsIconListener.cpp Tue Dec 21 15:16:59 2010 +0100
-+++ b/toolkit/system/gnome/nsAlertsIconListener.cpp Tue Dec 21 18:39:39 2010 +0100
-@@ -218,7 +218,11 @@
- {
- mNotification = notify_notification_new(mAlertTitle.get(),
- mAlertText.get(),
-- NULL, NULL);
-+ NULL
-+#if HAVE_LIBNOTIFY_BEFORE_07
-+ , NULL
-+#endif
-+ );
- if (!mNotification)
- return NS_ERROR_OUT_OF_MEMORY;
-
diff --git a/net-libs/xulrunner/xulrunner-9999.ebuild b/net-libs/xulrunner/xulrunner-9999.ebuild
index 09d6f92..96e27a2 100644
--- a/net-libs/xulrunner/xulrunner-9999.ebuild
+++ b/net-libs/xulrunner/xulrunner-9999.ebuild
@@ -32,16 +32,13 @@ S="${WORKDIR}/mozilla-central"
src_prepare() {
# Gentoo specific stuff
epatch "${FILESDIR}"/gentoo-specific.patch
-
+
eprefixify \
extensions/java/xpcom/interfaces/org/mozilla/xpcom/Mozilla.java \
xpcom/build/nsXPCOMPrivate.h \
xulrunner/installer/Makefile.in \
xulrunner/app/nsRegisterGREUnix.cpp
-
- # Up-to-date geek stuff
- epatch "${FILESDIR}"/libnotify-0.7-fix.patch
-
+
# fix double symbols due to double -ljemalloc
sed -i -e '/^LIBS += $(JEMALLOC_LIBS)/s/^/#/' \
xulrunner/stub/Makefile.in || die