summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2013-04-29 21:59:14 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 10:48:43 +0200
commit3fc772847d87c924ca5dc4bc382d2d144949ff69 (patch)
treefa1fd9e0bd0520f60aea340adda064032f1bb442 /net-print
parentRemove heirloom-sh since it is now in the main tree (diff)
downloadmv-3fc772847d87c924ca5dc4bc382d2d144949ff69.tar.gz
mv-3fc772847d87c924ca5dc4bc382d2d144949ff69.tar.bz2
mv-3fc772847d87c924ca5dc4bc382d2d144949ff69.zip
Bump noscript. Avoid redundent zsh link. Support EPREFIX. Simplify code
Diffstat (limited to 'net-print')
-rw-r--r--net-print/foo2zjs/ChangeLog3
-rw-r--r--net-print/foo2zjs/foo2zjs-20081129-r1.ebuild7
2 files changed, 6 insertions, 4 deletions
diff --git a/net-print/foo2zjs/ChangeLog b/net-print/foo2zjs/ChangeLog
index a6e74f63..e9d62297 100644
--- a/net-print/foo2zjs/ChangeLog
+++ b/net-print/foo2zjs/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 29 Apr 2013; Martin Väth <martin@mvath.de>:
+ Simplify for EAPI=5
+
02 Jan 2013; Martin Väth <martin@mvath.de>:
Depend only on virtual/udev
diff --git a/net-print/foo2zjs/foo2zjs-20081129-r1.ebuild b/net-print/foo2zjs/foo2zjs-20081129-r1.ebuild
index d2f57b82..6c0abb4e 100644
--- a/net-print/foo2zjs/foo2zjs-20081129-r1.ebuild
+++ b/net-print/foo2zjs/foo2zjs-20081129-r1.ebuild
@@ -99,7 +99,7 @@ src_unpack() {
}
src_compile() {
- emake getweb || die "Failed building getweb script"
+ emake getweb
# remove wget as we got the firmware with portage
sed -i -e "s/.*wget .*//" \
@@ -116,7 +116,7 @@ src_compile() {
done
if [ ${GOT} == 0 ]; then ./getweb all; fi
- emake || die "emake failed"
+ emake
}
src_install() {
@@ -124,6 +124,5 @@ src_install() {
use cups && dodir /usr/share/cups/model
- emake DESTDIR="${D}" install install-udev \
- || die "emake install failed"
+ emake DESTDIR="${ED}" install install-udev
}