summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2021-05-07 13:35:59 +0200
committerMartin Väth <martin@mvath.de>2021-05-07 13:35:59 +0200
commitcc28e9cf8703da7a20313a19a097b1458e2cafd0 (patch)
tree326cefde5d5a877de6694a9ed72d2710e950212c /dev-util
parentvirtual/freedesktop-icon-theme: Revision bump (diff)
downloadmv-cc28e9cf8703da7a20313a19a097b1458e2cafd0.tar.gz
mv-cc28e9cf8703da7a20313a19a097b1458e2cafd0.tar.bz2
mv-cc28e9cf8703da7a20313a19a097b1458e2cafd0.zip
python:3.9 and python:3.10
Signed-off-by: Martin Väth <martin@mvath.de>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/flawfinder/Manifest1
-rw-r--r--dev-util/flawfinder/flawfinder-2.0.15.ebuild36
-rw-r--r--dev-util/flawfinder/metadata.xml13
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-util/flawfinder/Manifest b/dev-util/flawfinder/Manifest
new file mode 100644
index 00000000..5b443b7b
--- /dev/null
+++ b/dev-util/flawfinder/Manifest
@@ -0,0 +1 @@
+DIST flawfinder-2.0.15.tar.gz 253677 BLAKE2B 5c4a0e21e0a7f144382c6ca25f713aef9bdb413d4bb5a73f66632ef365f55c75e755ab59cf92fb54dc2d043c8b88be8c28d5f5fca36df6795dabc00313b839f2 SHA512 12b637bae789ee86710c7d6ee203b811e78414ad5d173730bfffe3ea783a76ce999878c57ddaa8019744cac6bf94967663fd9fd80769d7a24b0a79d23c0b0d9d
diff --git a/dev-util/flawfinder/flawfinder-2.0.15.ebuild b/dev-util/flawfinder/flawfinder-2.0.15.ebuild
new file mode 100644
index 00000000..ae622da6
--- /dev/null
+++ b/dev-util/flawfinder/flawfinder-2.0.15.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9,10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Examines C/C++ source code for security flaws"
+HOMEPAGE="https://www.dwheeler.com/flawfinder/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i "s/${PN}.1.gz/${PN}.1/g" setup.py || die 'sed failed.'
+ default
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ local DOCS=( announcement ChangeLog README.md ${PN}.pdf )
+ distutils-r1_python_install_all
+}
diff --git a/dev-util/flawfinder/metadata.xml b/dev-util/flawfinder/metadata.xml
new file mode 100644
index 00000000..885fb2b1
--- /dev/null
+++ b/dev-util/flawfinder/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <upstream>
+ <changelog>https://sourceforge.net/p/flawfinder/code/ci/master/tree/ChangeLog</changelog>
+ <bugs-to>https://sourceforge.net/p/flawfinder/bugs/</bugs-to>
+ <remote-id type="sourceforge">flawfinder</remote-id>
+ </upstream>
+</pkgmetadata>