summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2022-12-22 08:07:21 +0100
committerMartin Väth <martin@mvath.de>2022-12-22 08:07:21 +0100
commite492d49b2cdff404d2fc3acfb79341946941baef (patch)
tree28e82c0dc3ab2001dbd804b5419f22421dabdcf5 /app-shells
parentx11-misc/gtkdialog: Remove, as it is back to gentoo repository (diff)
downloadmv-e492d49b2cdff404d2fc3acfb79341946941baef.tar.gz
mv-e492d49b2cdff404d2fc3acfb79341946941baef.tar.bz2
mv-e492d49b2cdff404d2fc3acfb79341946941baef.zip
split-usr: If unset use /usr/bin/sh instead of /bin/sh
Signed-off-by: Martin Väth <martin@mvath.de>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/runtitle/runtitle-2.11.ebuild4
-rw-r--r--app-shells/termcolors-mv/termcolors-mv-4.9.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/app-shells/runtitle/runtitle-2.11.ebuild b/app-shells/runtitle/runtitle-2.11.ebuild
index e11b2b30..1966e96d 100644
--- a/app-shells/runtitle/runtitle-2.11.ebuild
+++ b/app-shells/runtitle/runtitle-2.11.ebuild
@@ -11,11 +11,11 @@ SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc x86"
-IUSE=""
+IUSE="split-usr"
src_prepare() {
use prefix || sed -i \
- -e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}/bin/sh"'"' \
+ -e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}$(usex split-usr '' /usr)/bin/sh"'"' \
-- bin/* || die
default
}
diff --git a/app-shells/termcolors-mv/termcolors-mv-4.9.ebuild b/app-shells/termcolors-mv/termcolors-mv-4.9.ebuild
index a3069ae4..67f79ae6 100644
--- a/app-shells/termcolors-mv/termcolors-mv-4.9.ebuild
+++ b/app-shells/termcolors-mv/termcolors-mv-4.9.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="create +perl poor"
+IUSE="create +perl poor split-usr"
DEPEND="dev-lang/perl"
RDEPEND="create? ( dev-lang/perl )
perl? ( dev-lang/perl )"
@@ -26,7 +26,7 @@ For zsh, this happens if you use zshrc-mv"
src_prepare() {
use prefix || sed -i \
- -e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}/bin/sh"'"' \
+ -e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}$(usex split-usr '' /usr)/bin/sh"'"' \
-e '1s"^#!/usr/bin/env perl$"#!'"${EPREFIX}/usr/bin/perl"'"' \
-- bin/* || die
default