summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2011-12-19 15:43:29 +0100
committerMartin Väth <martin@mvath.de>2015-10-11 10:46:57 +0200
commitb8185f4ce01630cf49219e563373341d75de32cd (patch)
treed335b10e10adc97b109c5e7c685454edd3a286cc /app-admin
parentAdd portage-bashrc-mv. Update checksums (diff)
downloadmv-b8185f4ce01630cf49219e563373341d75de32cd.tar.gz
mv-b8185f4ce01630cf49219e563373341d75de32cd.tar.bz2
mv-b8185f4ce01630cf49219e563373341d75de32cd.zip
Add sudox and portage-bashrc-mv/metadata.xml
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/sudox/metadata.xml9
-rw-r--r--app-admin/sudox/sudox-99999999.ebuild26
2 files changed, 35 insertions, 0 deletions
diff --git a/app-admin/sudox/metadata.xml b/app-admin/sudox/metadata.xml
new file mode 100644
index 00000000..0c91bdcd
--- /dev/null
+++ b/app-admin/sudox/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+</maintainer>
+</pkgmetadata>
diff --git a/app-admin/sudox/sudox-99999999.ebuild b/app-admin/sudox/sudox-99999999.ebuild
new file mode 100644
index 00000000..40e675a6
--- /dev/null
+++ b/app-admin/sudox/sudox-99999999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+EAPI="4"
+
+EGIT_REPO_URI="git://github.com/vaeth/${PN}.git"
+[ -n "${EVCS_OFFLINE}" ] || EGIT_REPACK=true
+inherit git-2
+
+DESCRIPTION="sudox is a wrapper for sudo which can pass X authority data and deal with screen and tmux"
+HOMEPAGE="https://github.com/vaeth/${PN}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="zsh-completion"
+PROPERTIES="live"
+
+src_install() {
+ dobin sudox
+ if use zsh-completion
+ then insinto ${EPREFIX%/}/usr/share/zsh/site-functions
+ doins _sudox
+ fi
+}