aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2015-04-01 19:27:15 +0100
committerPaul Healy <lmiphay@gmail.com>2015-04-01 19:27:15 +0100
commit93cf4a295d57bb0ff636448852c6eba7b9b42464 (patch)
treea6d4d9f45214d9dba5036afec57dae1e2cd1fa4b /app-backup
parentadd perl Net::Bluetooth ebuild (diff)
downloadlmiphay-93cf4a295d57bb0ff636448852c6eba7b9b42464.tar.gz
lmiphay-93cf4a295d57bb0ff636448852c6eba7b9b42464.tar.bz2
lmiphay-93cf4a295d57bb0ff636448852c6eba7b9b42464.zip
add updated pdumpfs ebuild with patches for newer ruby and test case failure
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/pdumpfs/Manifest4
-rw-r--r--app-backup/pdumpfs/files/pdumpfs-test.patch10
-rw-r--r--app-backup/pdumpfs/files/pdumpfs.in.patch38
-rw-r--r--app-backup/pdumpfs/pdumpfs-1.3-r2.ebuild39
4 files changed, 91 insertions, 0 deletions
diff --git a/app-backup/pdumpfs/Manifest b/app-backup/pdumpfs/Manifest
new file mode 100644
index 0000000..e77de95
--- /dev/null
+++ b/app-backup/pdumpfs/Manifest
@@ -0,0 +1,4 @@
+AUX pdumpfs-test.patch 331 SHA256 4917c84068855b3eb2f19d0fcc2c518ae208bc81d2012a73ea05e5794099a090 SHA512 f47d823b5f15a38da61b7dbe54085782b700b3535a0fd5b1739ac3cb2639099823bc4c4b3ceabc325dce6e6053b00514f2b85b4fbf798843a764032f57a9cb0b WHIRLPOOL b4d657218e952811a0429dc52997605926614e19e5e92321dcee1f6844059e50f28153778d489742348fece845f05692d1e3d167b01635f86622fdd49c0745d6
+AUX pdumpfs.in.patch 916 SHA256 82483e7785c9c919a88b57bf8e07727ebf622e06fb205fd3be0f85c311ecc115 SHA512 7c994717f0d4bd354dbb7777658795bef046e43732ce84eee1f73bac08e935e2e6b04f3aba8d0147e6fe0fd3bd3c9d5e7e858477437010b431a95769d6fbd5a3 WHIRLPOOL 6d7f02d68b18a535343c7cf02d6b4b27d735b2d5339c97c76ffdacd7976f87e1bcac0e977dcfe09647144922ad89e78cbd1138458cd9e7928eff0914c4642ef3
+DIST pdumpfs-1.3.tar.gz 68210 SHA256 5f50158517f263370d59f6c794a1d45e947bb8c17be23e18a8f293ee13557377 SHA512 1299676982f1981aa55f0601f361ec24ac119067f5ecbbeebcf9f41ccd69df2f18a07ae5a6e77f30ca7606ee49ecfa516d6066a07c1edbb4d4796f34f02508c3 WHIRLPOOL 255ac184759f29b416315f47d4d9ffd5b6c84e6ee28192ce47601937dc05fd48db5f59e30e6d4f4c4c789e4bef0c4ee81dff76cf60bbe338560af42ae1278bf4
+EBUILD pdumpfs-1.3-r2.ebuild 708 SHA256 21ee7381a20a726c92b84d3719c2727949c2900405e9c8252ec3d5245cb53133 SHA512 4c0324279a74fc9e82768eddd24493bda86b4a175bbe2ece0ae7e37c4025cbcc8ae8478b4bb1ff06d35043be54c5177aa8fd1c4f3e1093a0e058131c81ee6e38 WHIRLPOOL aa3aae1d64f909fc558f07abfac4f0d1b56b43c7b14297a09d39584d8d1fd232fa850bd7a3bf6c197e33ea9461ed4bef873059a154f57f665fcda73e8a1e19c8
diff --git a/app-backup/pdumpfs/files/pdumpfs-test.patch b/app-backup/pdumpfs/files/pdumpfs-test.patch
new file mode 100644
index 0000000..d082497
--- /dev/null
+++ b/app-backup/pdumpfs/files/pdumpfs-test.patch
@@ -0,0 +1,10 @@
+--- tests/pdumpfs-test_orig 2004-08-10 07:54:28.000000000 +0100
++++ tests/pdumpfs-test 2015-04-01 11:24:35.948633870 +0100
+@@ -17,6 +17,7 @@
+
+ ../pdumpfs src dest > tmp.log || exit 1
+ diff -r src dest/$today/src || exit 1
++mkdir -p dest/$yesterday && rmdir dest/$yesterday
+ mv dest/$today dest/$yesterday
+
+ echo update > src/foo
diff --git a/app-backup/pdumpfs/files/pdumpfs.in.patch b/app-backup/pdumpfs/files/pdumpfs.in.patch
new file mode 100644
index 0000000..d17b3f4
--- /dev/null
+++ b/app-backup/pdumpfs/files/pdumpfs.in.patch
@@ -0,0 +1,38 @@
+--- pdumpfs.in_orig 2004-12-21 02:43:12.000000000 +0000
++++ pdumpfs.in 2015-04-01 10:58:22.671131947 +0100
+@@ -48,7 +48,7 @@
+ #
+
+ require 'find'
+-require 'ftools'
++require 'fileutils'
+ require 'getoptlong'
+ require 'date'
+
+@@ -868,7 +868,7 @@
+ today = File.join(dest, datedir(start_time), base)
+
+ File.umask(0077)
+- File.mkpath(today) unless @dry_run
++ FileUtils.mkpath(today) unless @dry_run
+ if latest
+ update_snapshot(src, latest, today)
+ else
+@@ -1018,7 +1018,7 @@
+
+ case type
+ when "directory"
+- File.mkpath(today)
++ FileUtils.mkpath(today)
+ when "unchanged"
+ File.force_link(latest, today)
+ when "updated"
+@@ -1089,7 +1089,7 @@
+
+ case type
+ when "directory"
+- File.mkpath(t)
++ FileUtils.mkpath(t)
+ when "new_file"
+ copy(s, t)
+ when "symlink"
diff --git a/app-backup/pdumpfs/pdumpfs-1.3-r2.ebuild b/app-backup/pdumpfs/pdumpfs-1.3-r2.ebuild
new file mode 100644
index 0000000..cde492f
--- /dev/null
+++ b/app-backup/pdumpfs/pdumpfs-1.3-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="a daily backup system similar to Plan9's dumpfs"
+HOMEPAGE="http://0xcc.net/pdumpfs/"
+SRC_URI="http://0xcc.net/pdumpfs/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="linguas_ja"
+
+DEPEND="
+ >=dev-lang/ruby-2.0.0_p598
+"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}.in.patch"
+ epatch "${FILESDIR}/${PN}-test.patch"
+}
+
+src_install() {
+ dobin pdumpfs || die
+
+ doman man/man8/pdumpfs.8
+ dohtml -r doc/*
+
+ if use linguas_ja; then
+ insinto /usr/share/man/ja/man8
+ doins man/ja/man8/pdumpfs.8
+ fi
+
+ dodoc ChangeLog README
+}