summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/tmxparser/files/tmxparser-fix-build-flags.patch')
-rw-r--r--dev-games/tmxparser/files/tmxparser-fix-build-flags.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-games/tmxparser/files/tmxparser-fix-build-flags.patch b/dev-games/tmxparser/files/tmxparser-fix-build-flags.patch
new file mode 100644
index 0000000..b6ab2d6
--- /dev/null
+++ b/dev-games/tmxparser/files/tmxparser-fix-build-flags.patch
@@ -0,0 +1,25 @@
+commit 332cf98e3e0d8b72c0fe025e910af22f66ef5507
+Author: Peter Asplund <peter.azp@gmail.com>
+Date: Wed Mar 1 12:16:40 2023 +0100
+
+ Remove build flags that are redundant for C++
+
+ These are:
+ strict-prototypes, missing-prototypes, old-style-definition
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 69a0df0..3e396e2 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -102,10 +102,7 @@ target_include_directories(tmxparser PUBLIC
+
+ target_compile_options(tmxparser
+ PRIVATE -pedantic
+- PRIVATE -Wall
+- PRIVATE -Werror=strict-prototypes
+- PRIVATE -Werror=old-style-definition
+- PRIVATE -Werror=missing-prototypes)
++ PRIVATE -Wall)
+ if(NOT USE_MINIZ)
+ target_compile_options(tmxparser
+ PRIVATE -Werror)