summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/presage/Manifest1
-rw-r--r--app-text/presage/files/presage-0.8.8-automagic.patch126
2 files changed, 127 insertions, 0 deletions
diff --git a/app-text/presage/Manifest b/app-text/presage/Manifest
index b19dfb5..1eb7d53 100644
--- a/app-text/presage/Manifest
+++ b/app-text/presage/Manifest
@@ -1,2 +1,3 @@
+AUX presage-0.8.8-automagic.patch 4399 SHA256 1ae5e85214dc400189cbb07ab4b34c16e778f6942fcea129fdb5397b5c5743ad SHA512 622883949554935c3fd12a08b1e117121ae38e5f958b4847eb83b29352df9831f4397a518372829be881bd0157a8e03fc1744e5e0585072869518e64a186bad5 WHIRLPOOL bdb531a6a66fc617d0e7ac73fb92979539d4cd134cd1ac9c3116473d0f2a6cdf39b0300e02f8974c24b708335952d4aaf669a32eee6b0c44c51c0fc872b86695
DIST presage-0.8.9.tar.gz 2568505 SHA256 5541e9b350cc603a8d412704dcfa21342369b5b07c6da91947c7523c51678cd0 SHA512 62206497283b3d7d29546399ea94c5b82d95c91f09c14e48098e1a8791018ccfdda26c46227195cdf706c0097e02bf382360e0a9c7e824edcd86fdfa5f4c3db1 WHIRLPOOL 029d3366c94fc52ba0a8337197158cc53d6aba8c276d2ddd52f5f58b864a7da2388af5d67342ece1817a7863fea2f6b675e76bb1e3555df4a1ddd67296a65188
EBUILD presage-0.8.9.ebuild 1086 SHA256 d20d982a6fd1f089fae2b4bef549c8a75ba14fe16e44ccfe54ea55ac06dd63b5 SHA512 a94a98f9405fed474d36ea22733da99011846a68c6a698a5df0d7eedfe5f465f782d90e562623a2b1b9f301590eba015292397b5faf8cd314b2ec5943e93445b WHIRLPOOL 3e968a2dc84b46580892a3617381209ca3d74d8d660b25cb87c2db282aee2e8f3e4faed75f3cbaf7b2b2046bb87e0b547eeb459ed689c30ffc5764be6fdbb27c
diff --git a/app-text/presage/files/presage-0.8.8-automagic.patch b/app-text/presage/files/presage-0.8.8-automagic.patch
new file mode 100644
index 0000000..dfb454b
--- /dev/null
+++ b/app-text/presage/files/presage-0.8.8-automagic.patch
@@ -0,0 +1,126 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -23,7 +23,7 @@
+
+
+ AC_INIT([presage],[0.8.8],[matteo.vescovi@yahoo.co.uk])
+-AM_INIT_AUTOMAKE([-Wall -Werror])
++AM_INIT_AUTOMAKE([-Wall])
+
+ AC_CONFIG_SRCDIR([src/lib/presage.cpp])
+ AC_CONFIG_HEADERS([config.h:config.hin])
+@@ -105,6 +105,13 @@
+ dnl ==================
+ dnl Checks for ncurses
+ dnl ==================
++AC_ARG_ENABLE([curses],
++ AS_HELP_STRING([--disable-curses],[disable curses support, needed for demo programs (default: enabled)]),
++ [enable_curses=$enableval],
++ [enable_curses=yes])
++
++if test "x$enable_curses" = "xyes"
++then
+ AC_CHECK_LIB([curses],
+ [initscr],
+ [have_curses_library=true],
+@@ -113,12 +120,19 @@
+ [have_curses_header=true],
+ [AC_MSG_WARN([curses header file not found. curses demo programs will not be built.])],
+ [])
+-AM_CONDITIONAL([HAVE_CURSES], [test "x$have_curses_library" = "xtrue" -a "x$have_curses_header" = "xtrue"])
++fi
++AM_CONDITIONAL([HAVE_CURSES], [test "x$have_curses_library" = "xtrue" -a "x$have_curses_header" = "xtrue" -a "x$enable_curses" = "xyes"])
+
+
+ dnl ==================
+ dnl Checks for tinyxml
+ dnl ==================
++AC_ARG_ENABLE([tinyxml],
++ AS_HELP_STRING([--disable-tinyxml],[disable tinyxml support (default: enabled)]),
++ [enable_tinyxml=$enableval],
++ [enable_tinyxml=yes])
++if test "x$enable_tinyxml" = "xtrue"
++then
+ AC_CHECK_LIB([tinyxml],
+ [main],
+ [have_tinyxml_library=true],
+@@ -127,6 +141,7 @@
+ [have_tinyxml_header=true],
+ [AC_MSG_WARN([tinyxml library not found. Embedded tinyxml library will be built.])],
+ [])
++fi
+ if test "x$have_tinyxml_library" != "xtrue" -o "x$have_tinyxml_header" != "xtrue"
+ then
+ build_tinyxml=yes
+@@ -134,7 +149,7 @@
+ build_tinyxml=no
+ AC_DEFINE([TIXML_USE_STL], [1], [Define to 1 to use STL string in TinyXML])
+ fi
+-AM_CONDITIONAL([BUILD_TINYXML], [test "x$build_tinyxml" = "xyes"])
++AM_CONDITIONAL([BUILD_TINYXML], [test "x$build_tinyxml" = "xyes" -a "x$enable_tinyxml" = "xyes"])
+
+
+ dnl =================
+@@ -203,10 +218,15 @@
+ dnl ==================
+ dnl Checks for CppUnit
+ dnl ==================
++AC_ARG_ENABLE([tests],
++ AS_HELP_STRING([--enable-tests],[enable tests (default: disabled)]),
++ [enable_tests=$enableval],
++ [enable_tests=no])
++
+ AM_PATH_CPPUNIT([1.9.6],
+ [],
+ [AC_MSG_WARN([CppUnit not found. Unit tests will not be built. CppUnit can be obtained from http://cppunit.sourceforge.net.])])
+-AM_CONDITIONAL([HAVE_CPPUNIT], [test "$CPPUNIT_LIBS"])
++AM_CONDITIONAL([HAVE_CPPUNIT], [test "$CPPUNIT_LIBS" -a "x$enable_tests" = "xyes"])
+
+
+ dnl ============================
+@@ -216,6 +236,7 @@
+ dnl ===============
+ dnl Checks for SWIG
+ dnl ===============
++
+ AC_PATH_PROG([SWIG], [swig])
+ if test ! "$SWIG"
+ then
+@@ -227,6 +248,11 @@
+ dnl =================
+ dnl Checks for Python
+ dnl =================
++AC_ARG_ENABLE([python],
++ AS_HELP_STRING([--disable-python],[disable python support, needed for python bindings (default: enabled)]),
++ [enable_python=$enableval],
++ [enable_python=yes])
++
+ AM_PATH_PYTHON([2.0],
+ [],
+ [AC_MSG_WARN([Python not found. Python is required to build presage python binding. Python can be obtained from http://www.python.org])])
+@@ -238,7 +264,7 @@
+ [AC_MSG_WARN([Python.h header file not found. Python development files are required to build presage python binding. Python can be obtained from http://www.python.org])],
+ [])
+ fi
+-AM_CONDITIONAL([HAVE_PYTHON], [test "$PYTHON" -a "x$have_python_header" = "xtrue"])
++AM_CONDITIONAL([HAVE_PYTHON], [test "$PYTHON" -a "x$have_python_header" = "xtrue" -a "x$enable_python" = "xyes"])
+
+
+ AC_ARG_ENABLE([python-binding],
+@@ -262,6 +288,7 @@
+ dnl ======================
+ dnl Checks for dbus python
+ dnl ======================
++
+ have_dbus_python=no
+ AC_MSG_CHECKING(for python dbus module)
+ $PYTHON -c "import dbus" 2&>/dev/null
+@@ -272,7 +299,7 @@
+ have_dbus_python=no
+ fi
+ AC_MSG_RESULT($have_dbus_python)
+-AM_CONDITIONAL([HAVE_DBUS_PYTHON], [test "x$have_dbus_python" = "xyes"])
++AM_CONDITIONAL([HAVE_DBUS_PYTHON], [test "x$have_dbus_python" = "xyes" -a "x$enable_python" = "xyes"])
+
+
+ dnl ========================