summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/chromium/chromium-64.0.3282.14.ebuild')
-rw-r--r--www-client/chromium/chromium-64.0.3282.14.ebuild16
1 files changed, 6 insertions, 10 deletions
diff --git a/www-client/chromium/chromium-64.0.3282.14.ebuild b/www-client/chromium/chromium-64.0.3282.14.ebuild
index e436cbd1b599..c0f32ba37a41 100644
--- a/www-client/chromium/chromium-64.0.3282.14.ebuild
+++ b/www-client/chromium/chromium-64.0.3282.14.ebuild
@@ -539,9 +539,13 @@ src_configure() {
"$@" || die
}
-host_binary() {
+src_compile() {
+ # Calling this here supports resumption via FEATURES=keepwork
+ python_setup
+
+ # Build mksnapshot and pax-mark it.
local x
- for x; do
+ for x in mksnapshot v8_context_snapshot_generator; do
if tc-is-cross-compiler; then
eninja -C out/Release "host/${x}"
pax-mark m "out/Release/host/${x}"
@@ -550,14 +554,6 @@ host_binary() {
pax-mark m "out/Release/${x}"
fi
done
-}
-
-src_compile() {
- # Calling this here supports resumption via FEATURES=keepwork
- python_setup
-
- # Build mksnapshot and pax-mark it.
- host_binary mksnapshot v8_context_snapshot_generator
# Work around circular dep issue
# https://chromium-review.googlesource.com/c/chromium/src/+/617768