summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'virtual/ruby-ssl')
-rw-r--r--virtual/ruby-ssl/ruby-ssl-10.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/virtual/ruby-ssl/ruby-ssl-10.ebuild b/virtual/ruby-ssl/ruby-ssl-10.ebuild
new file mode 100644
index 000000000000..9efd56b247a9
--- /dev/null
+++ b/virtual/ruby-ssl/ruby-ssl-10.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+inherit ruby-ng
+
+DESCRIPTION="Virtual ebuild for the Ruby OpenSSL bindings"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ ruby_targets_ruby22? ( dev-lang/ruby:2.2[ssl] )
+ ruby_targets_ruby23? ( dev-lang/ruby:2.3[ssl] )
+ ruby_targets_ruby24? ( dev-lang/ruby:2.4[ssl] )
+ ruby_targets_ruby25? ( dev-lang/ruby:2.5[ssl] )
+"
+
+pkg_setup() { :; }
+src_unpack() { :; }
+src_prepare() { :; }
+src_compile() { :; }
+src_install() { :; }
+pkg_preinst() { :; }
+pkg_postinst() { :; }