summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/memwatch/memwatch-0.3.3-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-process/memwatch/memwatch-0.3.3-r1.ebuild b/sys-process/memwatch/memwatch-0.3.3-r1.ebuild
new file mode 100644
index 000000000000..3d95dc363e12
--- /dev/null
+++ b/sys-process/memwatch/memwatch-0.3.3-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_REMOVE_MODULES_LIST=( FindCurses )
+inherit cmake
+
+DESCRIPTION="Interactive memory viewer"
+HOMEPAGE="https://unixdev.ru/memwatch"
+SRC_URI="http://unixdev.ru/src/${P}.tar.gz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses:0="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -e "s/^set(CMAKE_C_FLAGS.*/set(CMAKE_C_FLAGS \"${CFLAGS}\")/" \
+ -e "1s/^/project(${PN})\n/" \
+ -i CMakeLists.txt || die "can't patch CMakeLists.txt"
+
+ cmake_src_prepare
+}