summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fabric')
-rw-r--r--sys-fabric/mstflint/Manifest1
-rw-r--r--sys-fabric/mstflint/mstflint-4.16.0_p2.ebuild46
2 files changed, 0 insertions, 47 deletions
diff --git a/sys-fabric/mstflint/Manifest b/sys-fabric/mstflint/Manifest
index e708e215ed11..e3914046bff0 100644
--- a/sys-fabric/mstflint/Manifest
+++ b/sys-fabric/mstflint/Manifest
@@ -1,2 +1 @@
-DIST mstflint-4.16.0_p2.tar.gz 4534457 BLAKE2B c199cd0b4eed8ecc20b8ab89235035b7ad258fe583c464dafb31a1e5ba8f6cfd745b132ff12631fa0d98c2d94f16ca69c908c0b6ad94391ec1a3e56ba9967d59 SHA512 03a6b055384b9fab44a31ba6f2de02d1580e08af981c1cad5111a96279872ea960024bfa9debbbdb36019b88713906c3c59d3910a11f169ad5f3a0090bc6c7df
DIST mstflint-4.18.0_p1.tar.gz 4877851 BLAKE2B 7fb995561155ccc73b0c36d2994c0398483a92788c5ce045f0263a3e5b0ff7230ca8bb0f5b821e957d5879e0629f11716b179e3bc581849335cc95715631c1d6 SHA512 aed2302dc88b9b95892eb6dd929a922ac6257ddae808db656c7fd01c393f9f0a0d3aa4e13da6c07fe0118cd48a43795f39cc16e619408b05e6bed7d085dbf0d4
diff --git a/sys-fabric/mstflint/mstflint-4.16.0_p2.ebuild b/sys-fabric/mstflint/mstflint-4.16.0_p2.ebuild
deleted file mode 100644
index bac06d183ae9..000000000000
--- a/sys-fabric/mstflint/mstflint-4.16.0_p2.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools
-
-DESCRIPTION="Mstflint - an open source version of MFT (Mellanox Firmware Tools)"
-HOMEPAGE="https://github.com/Mellanox/mstflint"
-LICENSE="|| ( GPL-2 BSD-2 )"
-KEYWORDS="~amd64 ~x86"
-EGIT_COMMIT="bd8852742cbd5d4d5eb0d67e000275c953cc0820"
-MY_PV=${PV/_p/-}
-MY_P=""
-SRC_URI="https://github.com/Mellanox/mstflint/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
-IUSE="adb-generic-tools inband ssl"
-SLOT="0"
-RDEPEND="dev-db/sqlite:3=
- sys-libs/zlib:=
- inband? ( sys-fabric/libibmad )
- adb-generic-tools? (
- dev-libs/boost:=
- dev-libs/expat:=
- )
- ssl? ( dev-libs/openssl:= )"
-DEPEND="${RDEPEND}"
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-src_prepare() {
- default
- echo '#define TOOLS_GIT_SHA "'${EGIT_COMMIT}'"' > ./common/gitversion.h || die
-}
-
-src_configure() {
- eautoreconf
- econf $(use_enable inband) $(use_enable ssl openssl) $(use adb-generic-tools && printf -- '--enable-adb-generic-tools')
-}
-
-src_compile() {
- if use adb-generic-tools; then
- pushd ext_libs/json >/dev/null || die
- emake
- popd >/dev/null || die
- fi
- default
-}