summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-common/clang-common-10.0.0.9999.ebuild6
-rw-r--r--sys-devel/clang-common/clang-common-9.0.1.9999.ebuild8
-rw-r--r--sys-devel/clang/clang-10.0.0.9999.ebuild36
-rw-r--r--sys-devel/clang/clang-9.0.1.9999.ebuild38
-rw-r--r--sys-devel/lld/lld-10.0.0.9999.ebuild20
-rw-r--r--sys-devel/lld/lld-9.0.1.9999.ebuild22
-rw-r--r--sys-devel/llvm-common/llvm-common-10.0.0.9999.ebuild6
-rw-r--r--sys-devel/llvm-common/llvm-common-9.0.1.9999.ebuild8
-rw-r--r--sys-devel/llvm/llvm-10.0.0.9999.ebuild9
-rw-r--r--sys-devel/llvm/llvm-9.0.1.9999.ebuild11
10 files changed, 67 insertions, 97 deletions
diff --git a/sys-devel/clang-common/clang-common-10.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-10.0.0.9999.ebuild
index d1ce28354dec..6b707e3d41ff 100644
--- a/sys-devel/clang-common/clang-common-10.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-10.0.0.9999.ebuild
@@ -8,8 +8,8 @@ inherit bash-completion-r1 git-r3
DESCRIPTION="Common files shared between multiple slots of clang"
HOMEPAGE="https://llvm.org/"
SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/clang.git
- https://github.com/llvm-mirror/clang.git"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+S=${WORKDIR}/${P}/clang
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -20,7 +20,7 @@ PDEPEND="sys-devel/clang:*"
src_unpack() {
git-r3_fetch
- git-r3_checkout '' '' '' utils/bash-autocomplete.sh
+ git-r3_checkout '' '' '' clang/utils/bash-autocomplete.sh
}
src_configure() { :; }
diff --git a/sys-devel/clang-common/clang-common-9.0.1.9999.ebuild b/sys-devel/clang-common/clang-common-9.0.1.9999.ebuild
index cc703baf0c50..eecb0ff749dc 100644
--- a/sys-devel/clang-common/clang-common-9.0.1.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-9.0.1.9999.ebuild
@@ -8,9 +8,9 @@ inherit bash-completion-r1 git-r3
DESCRIPTION="Common files shared between multiple slots of clang"
HOMEPAGE="https://llvm.org/"
SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/clang.git
- https://github.com/llvm-mirror/clang.git"
-EGIT_BRANCH="release_90"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+EGIT_BRANCH="release/9.x"
+S=${WORKDIR}/${P}/clang
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -21,7 +21,7 @@ PDEPEND="sys-devel/clang:*"
src_unpack() {
git-r3_fetch
- git-r3_checkout '' '' '' utils/bash-autocomplete.sh
+ git-r3_checkout '' '' '' clang/utils/bash-autocomplete.sh
}
src_configure() { :; }
diff --git a/sys-devel/clang/clang-10.0.0.9999.ebuild b/sys-devel/clang/clang-10.0.0.9999.ebuild
index aa2c3a2ba5d8..7213d45d1617 100644
--- a/sys-devel/clang/clang-10.0.0.9999.ebuild
+++ b/sys-devel/clang/clang-10.0.0.9999.ebuild
@@ -14,11 +14,9 @@ inherit cmake-utils git-r3 llvm multilib-minimal multiprocessing \
DESCRIPTION="C language family frontend for LLVM"
HOMEPAGE="https://llvm.org/"
SRC_URI=""
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
# We need extra level of indirection for CLANG_RESOURCE_DIR
-S=${WORKDIR}/x/y/${P}
-
-EGIT_REPO_URI="https://git.llvm.org/git/clang.git
- https://github.com/llvm-mirror/clang.git"
+S=${WORKDIR}/x/${P}/clang
# Keep in sync with sys-devel/llvm
ALL_LLVM_EXPERIMENTAL_TARGETS=( ARC AVR )
@@ -82,26 +80,16 @@ pkg_setup() {
src_unpack() {
# create extra parent dir for CLANG_RESOURCE_DIR
- mkdir -p x/y || die
- cd x/y || die
-
- git-r3_fetch "https://git.llvm.org/git/clang-tools-extra.git
- https://github.com/llvm-mirror/clang-tools-extra.git"
- if use test; then
- # needed for patched gtest
- git-r3_fetch "https://git.llvm.org/git/llvm.git
- https://github.com/llvm-mirror/llvm.git"
- fi
- git-r3_fetch
+ mkdir -p x || die
- git-r3_checkout https://llvm.org/git/clang-tools-extra.git \
- "${S}"/tools/extra
- if use test; then
- git-r3_checkout https://llvm.org/git/llvm.git \
- "${WORKDIR}"/llvm '' \
- lib/Testing/Support utils/{lit,llvm-lit,unittest}
- fi
- git-r3_checkout "${EGIT_REPO_URI}" "${S}"
+ local dirs=( clang clang-tools-extra )
+ use test && dirs+=(
+ llvm/lib/Testing/Support llvm/utils/{lit,llvm-lit,unittest}
+ )
+ git-r3_fetch
+ git-r3_checkout "${EGIT_REPO_URI}" "${WORKDIR}/x/${P}" '' "${dirs[@]}"
+ mv "${WORKDIR}/x/${P}/clang-tools-extra" \
+ "${WORKDIR}/x/${P}/clang/tools/extra" || die
}
check_distribution_components() {
@@ -258,7 +246,7 @@ multilib_src_configure() {
-DCLANG_ENABLE_STATIC_ANALYZER=$(usex static-analyzer)
)
use test && mycmakeargs+=(
- -DLLVM_MAIN_SRC_DIR="${WORKDIR}/llvm"
+ -DLLVM_MAIN_SRC_DIR="${WORKDIR}/x/${P}/llvm"
-DLLVM_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
)
diff --git a/sys-devel/clang/clang-9.0.1.9999.ebuild b/sys-devel/clang/clang-9.0.1.9999.ebuild
index 848de712e241..788ba009941a 100644
--- a/sys-devel/clang/clang-9.0.1.9999.ebuild
+++ b/sys-devel/clang/clang-9.0.1.9999.ebuild
@@ -14,12 +14,10 @@ inherit cmake-utils git-r3 llvm multilib-minimal multiprocessing \
DESCRIPTION="C language family frontend for LLVM"
HOMEPAGE="https://llvm.org/"
SRC_URI=""
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+EGIT_BRANCH="release/9.x"
# We need extra level of indirection for CLANG_RESOURCE_DIR
-S=${WORKDIR}/x/y/${P}
-
-EGIT_REPO_URI="https://git.llvm.org/git/clang.git
- https://github.com/llvm-mirror/clang.git"
-EGIT_BRANCH="release_90"
+S=${WORKDIR}/x/${P}/clang
# Keep in sync with sys-devel/llvm
ALL_LLVM_TARGETS=( AArch64 AMDGPU ARM BPF Hexagon Lanai Mips MSP430
@@ -90,26 +88,16 @@ pkg_setup() {
src_unpack() {
# create extra parent dir for CLANG_RESOURCE_DIR
- mkdir -p x/y || die
- cd x/y || die
-
- git-r3_fetch "https://git.llvm.org/git/clang-tools-extra.git
- https://github.com/llvm-mirror/clang-tools-extra.git"
- if use test; then
- # needed for patched gtest
- git-r3_fetch "https://git.llvm.org/git/llvm.git
- https://github.com/llvm-mirror/llvm.git"
- fi
- git-r3_fetch
+ mkdir -p x || die
- git-r3_checkout https://llvm.org/git/clang-tools-extra.git \
- "${S}"/tools/extra
- if use test; then
- git-r3_checkout https://llvm.org/git/llvm.git \
- "${WORKDIR}"/llvm '' \
- lib/Testing/Support utils/{lit,llvm-lit,unittest}
- fi
- git-r3_checkout "${EGIT_REPO_URI}" "${S}"
+ local dirs=( clang clang-tools-extra )
+ use test && dirs+=(
+ llvm/lib/Testing/Support llvm/utils/{lit,llvm-lit,unittest}
+ )
+ git-r3_fetch
+ git-r3_checkout "${EGIT_REPO_URI}" "${WORKDIR}/x/${P}" '' "${dirs[@]}"
+ mv "${WORKDIR}/x/${P}/clang-tools-extra" \
+ "${WORKDIR}/x/${P}/clang/tools/extra" || die
}
multilib_src_configure() {
@@ -143,7 +131,7 @@ multilib_src_configure() {
-DCLANG_ENABLE_STATIC_ANALYZER=$(usex static-analyzer)
)
use test && mycmakeargs+=(
- -DLLVM_MAIN_SRC_DIR="${WORKDIR}/llvm"
+ -DLLVM_MAIN_SRC_DIR="${WORKDIR}/x/${P}/llvm"
-DLLVM_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
)
diff --git a/sys-devel/lld/lld-10.0.0.9999.ebuild b/sys-devel/lld/lld-10.0.0.9999.ebuild
index 9d1c88d828d3..c0a2e884c80d 100644
--- a/sys-devel/lld/lld-10.0.0.9999.ebuild
+++ b/sys-devel/lld/lld-10.0.0.9999.ebuild
@@ -13,8 +13,8 @@ inherit cmake-utils git-r3 llvm multiprocessing python-any-r1
DESCRIPTION="The LLVM linker (link editor)"
HOMEPAGE="https://llvm.org/"
SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/lld.git
- https://github.com/llvm-mirror/lld.git"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+S=${WORKDIR}/${P}/lld
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -39,18 +39,10 @@ pkg_setup() {
}
src_unpack() {
- if use test; then
- # needed for patched gtest
- git-r3_fetch "https://git.llvm.org/git/llvm.git
- https://github.com/llvm-mirror/llvm.git"
- fi
+ local dirs=( lld )
+ use test && dirs+=( llvm/utils/{lit,unittest} )
git-r3_fetch
-
- if use test; then
- git-r3_checkout https://llvm.org/git/llvm.git \
- "${WORKDIR}"/llvm '' utils/{lit,unittest}
- fi
- git-r3_checkout
+ git-r3_checkout '' '' '' "${dirs[@]}"
}
src_configure() {
@@ -61,7 +53,7 @@ src_configure() {
)
use test && mycmakeargs+=(
-DLLVM_BUILD_TESTS=ON
- -DLLVM_MAIN_SRC_DIR="${WORKDIR}/llvm"
+ -DLLVM_MAIN_SRC_DIR="${WORKDIR}/${P}/llvm"
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
-DLLVM_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
)
diff --git a/sys-devel/lld/lld-9.0.1.9999.ebuild b/sys-devel/lld/lld-9.0.1.9999.ebuild
index 6935200f15c6..07ffc6f41c97 100644
--- a/sys-devel/lld/lld-9.0.1.9999.ebuild
+++ b/sys-devel/lld/lld-9.0.1.9999.ebuild
@@ -13,9 +13,9 @@ inherit cmake-utils git-r3 llvm multiprocessing python-any-r1
DESCRIPTION="The LLVM linker (link editor)"
HOMEPAGE="https://llvm.org/"
SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/lld.git
- https://github.com/llvm-mirror/lld.git"
-EGIT_BRANCH="release_90"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+EGIT_BRANCH="release/9.x"
+S=${WORKDIR}/${P}/lld
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -40,18 +40,10 @@ pkg_setup() {
}
src_unpack() {
- if use test; then
- # needed for patched gtest
- git-r3_fetch "https://git.llvm.org/git/llvm.git
- https://github.com/llvm-mirror/llvm.git"
- fi
+ local dirs=( lld )
+ use test && dirs+=( llvm/utils/{lit,unittest} )
git-r3_fetch
-
- if use test; then
- git-r3_checkout https://llvm.org/git/llvm.git \
- "${WORKDIR}"/llvm '' utils/{lit,unittest}
- fi
- git-r3_checkout
+ git-r3_checkout '' '' '' "${dirs[@]}"
}
src_configure() {
@@ -62,7 +54,7 @@ src_configure() {
)
use test && mycmakeargs+=(
-DLLVM_BUILD_TESTS=ON
- -DLLVM_MAIN_SRC_DIR="${WORKDIR}/llvm"
+ -DLLVM_MAIN_SRC_DIR="${WORKDIR}/${P}/llvm"
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
-DLLVM_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
)
diff --git a/sys-devel/llvm-common/llvm-common-10.0.0.9999.ebuild b/sys-devel/llvm-common/llvm-common-10.0.0.9999.ebuild
index 11a022242bd0..7edf27153de4 100644
--- a/sys-devel/llvm-common/llvm-common-10.0.0.9999.ebuild
+++ b/sys-devel/llvm-common/llvm-common-10.0.0.9999.ebuild
@@ -8,8 +8,8 @@ inherit git-r3
DESCRIPTION="Common files shared between multiple slots of LLVM"
HOMEPAGE="https://llvm.org/"
SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
- https://github.com/llvm-mirror/llvm.git"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+S=${WORKDIR}/${P}/llvm
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -20,7 +20,7 @@ RDEPEND="!sys-devel/llvm:0"
src_unpack() {
git-r3_fetch
- git-r3_checkout '' '' '' utils/vim
+ git-r3_checkout '' '' '' llvm/utils/vim
}
src_configure() { :; }
diff --git a/sys-devel/llvm-common/llvm-common-9.0.1.9999.ebuild b/sys-devel/llvm-common/llvm-common-9.0.1.9999.ebuild
index ae78e1164ce5..b3b79ac4e6c6 100644
--- a/sys-devel/llvm-common/llvm-common-9.0.1.9999.ebuild
+++ b/sys-devel/llvm-common/llvm-common-9.0.1.9999.ebuild
@@ -8,9 +8,9 @@ inherit git-r3
DESCRIPTION="Common files shared between multiple slots of LLVM"
HOMEPAGE="https://llvm.org/"
SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
- https://github.com/llvm-mirror/llvm.git"
-EGIT_BRANCH="release_90"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+EGIT_BRANCH="release/9.x"
+S=${WORKDIR}/${P}/llvm
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -21,7 +21,7 @@ RDEPEND="!sys-devel/llvm:0"
src_unpack() {
git-r3_fetch
- git-r3_checkout '' '' '' utils/vim
+ git-r3_checkout '' '' '' llvm/utils/vim
}
src_configure() { :; }
diff --git a/sys-devel/llvm/llvm-10.0.0.9999.ebuild b/sys-devel/llvm/llvm-10.0.0.9999.ebuild
index 77a6c8423834..c5cd658cd7b0 100644
--- a/sys-devel/llvm/llvm-10.0.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-10.0.0.9999.ebuild
@@ -14,8 +14,8 @@ inherit cmake-utils git-r3 multilib-minimal multiprocessing pax-utils \
DESCRIPTION="Low Level Virtual Machine"
HOMEPAGE="https://llvm.org/"
SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
- https://github.com/llvm-mirror/llvm.git"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+S=${WORKDIR}/${P}/llvm
# Those are in lib/Targets, without explicit CMakeLists.txt mention
ALL_LLVM_EXPERIMENTAL_TARGETS=( ARC AVR )
@@ -91,6 +91,11 @@ python_check_deps() {
has_version -b "dev-python/sphinx[${PYTHON_USEDEP}]"
}
+src_unpack() {
+ git-r3_fetch
+ git-r3_checkout '' '' '' llvm
+}
+
check_live_ebuild() {
local prod_targets=(
$(sed -n -e '/set(LLVM_ALL_TARGETS/,/)/p' CMakeLists.txt \
diff --git a/sys-devel/llvm/llvm-9.0.1.9999.ebuild b/sys-devel/llvm/llvm-9.0.1.9999.ebuild
index 5ff9e20d7e12..45e29fba1c7b 100644
--- a/sys-devel/llvm/llvm-9.0.1.9999.ebuild
+++ b/sys-devel/llvm/llvm-9.0.1.9999.ebuild
@@ -14,9 +14,9 @@ inherit cmake-utils git-r3 multilib-minimal multiprocessing pax-utils \
DESCRIPTION="Low Level Virtual Machine"
HOMEPAGE="https://llvm.org/"
SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
- https://github.com/llvm-mirror/llvm.git"
-EGIT_BRANCH="release_90"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+EGIT_BRANCH="release/9.x"
+S=${WORKDIR}/${P}/llvm
# Keep in sync with CMakeLists.txt
ALL_LLVM_TARGETS=( AArch64 AMDGPU ARM BPF Hexagon Lanai Mips MSP430
@@ -88,6 +88,11 @@ python_check_deps() {
has_version -b "dev-python/sphinx[${PYTHON_USEDEP}]"
}
+src_unpack() {
+ git-r3_fetch
+ git-r3_checkout '' '' '' llvm
+}
+
src_prepare() {
# Fix llvm-config for shared linking and sane flags
# https://bugs.gentoo.org/show_bug.cgi?id=565358