summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libxc/Manifest1
-rw-r--r--sci-libs/libxc/libxc-5.1.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sci-libs/libxc/Manifest b/sci-libs/libxc/Manifest
index 6e1e39d9071f..bf6696b1f31f 100644
--- a/sci-libs/libxc/Manifest
+++ b/sci-libs/libxc/Manifest
@@ -1,2 +1,3 @@
DIST libxc-2.2.3.tar.gz 734714 BLAKE2B c5c4c3aec3373b8b481de8ec1779366b6916899e0b77964cbde0e83904b351e009b14a3ff64e9f020640e6ebf68d78828615b8abf83a46fdf86ea16480083643 SHA512 bfcd88c1946e459227e9b1a32c513f0e68ae7a5497925ac6e692085542526ebad9fe2cd5722077c839c06dbaaceca601c7f615ee6936e638eb150a9d68278d5a
DIST libxc-5.1.0.tar.gz 42951890 BLAKE2B 32ce8d15547882455e01cbf9d4ee8780b97059d5b710f25b799779a5efe7326c376a53111102f3d5e0853bb89ba1f4dd9c2f219cfb4d3f91a2f6e1100f8fb47a SHA512 615b82290e87a48484f6dbe41cd8f1538ba6201b99fc97be2db64b66232fa4349fe6cebfb51566098db3cabd7aff662bb7ace43a811507bff2e93afd03d56ce4
+DIST libxc-5.1.1.tar.gz 43264474 BLAKE2B 887dc11a6385559edc5e2e62f3e00b16ff5695e1c384196bc3efe5aceff0a223d5f69fafaa08290bdf72f95390cb82d43e541ffaf6c4569e850eed3cb63aa5f6 SHA512 467ff09c39df30ccd50447dda5bbfe9e5f3e8f2876e069b6c16d49b3cfcc8b45316640f5b16c56ff7645355be9ec4dc571c794a17accb7731cd22bcce53f8b99
diff --git a/sci-libs/libxc/libxc-5.1.1.ebuild b/sci-libs/libxc/libxc-5.1.1.ebuild
new file mode 100644
index 000000000000..bade5f34f401
--- /dev/null
+++ b/sci-libs/libxc/libxc-5.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools fortran-2
+
+DESCRIPTION="A library of exchange-correlation functionals for use in DFT"
+HOMEPAGE="https://octopus-code.org/wiki/Libxc"
+SRC_URI="https://gitlab.com/libxc/libxc/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="fortran test"
+RESTRICT="!test? ( test )"
+
+pkg_setup() {
+ use fortran && fortran-2_pkg_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ --disable-static \
+ $(use_enable fortran)
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${ED}" -name '*.la' -type f -delete || die
+}