summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/linux-gpib/files/linux-gpib-3.2.15-build.patch')
-rw-r--r--sci-libs/linux-gpib/files/linux-gpib-3.2.15-build.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/sci-libs/linux-gpib/files/linux-gpib-3.2.15-build.patch b/sci-libs/linux-gpib/files/linux-gpib-3.2.15-build.patch
new file mode 100644
index 000000000000..14a186875748
--- /dev/null
+++ b/sci-libs/linux-gpib/files/linux-gpib-3.2.15-build.patch
@@ -0,0 +1,44 @@
+diff -ruN linux-gpib-3.2.15-0-orig/drivers/Makefile.am linux-gpib-3.2.15/drivers/Makefile.am
+--- linux-gpib-3.2.15-0-orig/drivers/Makefile.am 2007-04-19 17:21:04.000000000 +0200
++++ linux-gpib-3.2.15/drivers/Makefile.am 2011-01-24 23:20:59.000000000 +0100
+@@ -27,39 +27,13 @@
+ CC="$(LINUX_CC) -I@abs_top_srcdir@ -I@abs_top_srcdir@/drivers/gpib/include -I@abs_top_srcdir@/include" \
+ SUBDIRS="$(GPIB_ABS_MODULE_SUBDIR)"
+
+-install-data-hook: device-file-check /etc/gpib.conf
++install-data-hook: /etc/gpib.conf
+ $(MAKE) -C $(LINUX_SRCDIR) V=1 modules_install\
+ CC="$(LINUX_CC) -I@abs_top_srcdir@ -I@abs_top_srcdir@/driver/include -I@abs_top_srcdir@/include" \
+ SUBDIRS="$(GPIB_ABS_MODULE_SUBDIR)" INSTALL_MOD_DIR="gpib"
+- $(DEPMOD) -ae
+-
+-/dev/gpib0:
+- groupadd gpib || echo "group gpib exists"
+- for i in `seq 0 15`; \
+- do \
+- mknod -m u=rw,g=rw,o= /dev/gpib$${i} c $(IBMAJOR) $${i} || exit 1; \
+- chown root:gpib /dev/gpib$${i}; \
+- done
+-
+-.PHONY : device-file-check
+-device-file-check: /dev/gpib0
+- @if [ ! -c /dev/gpib0 ]; then \
+- if [ -a /dev/gpib0 ]; then \
+- echo "A file or directory called /dev/gpib0 exists but it is not" \
+- "a character device. Delete or move it and try again."; \
+- exit 1; \
+- fi; \
+- fi
+- @ls -l /dev/gpib0 | grep -q "$(IBMAJOR)"; \
+- if [ $$? != 0 ]; then \
+- echo "/dev/gpib0 has the wrong major number. " \
+- "Delete your /dev/gpibX files and try again."; \
+- exit 1; \
+- fi
+
+ #should move this to util/templates Makefile.am when it exists
+ /etc/gpib.conf:
+- $(INSTALL_DATA) -D $(top_srcdir)/util/templates/gpib.conf /etc/gpib.conf
+
+ #make sure compiled files, etc don't make it into distribution tarballs
+ dist-hook: