summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/uchime')
-rw-r--r--sci-biology/uchime/files/CMakeLists.txt7
-rw-r--r--sci-biology/uchime/uchime-4.2.40.ebuild16
2 files changed, 11 insertions, 12 deletions
diff --git a/sci-biology/uchime/files/CMakeLists.txt b/sci-biology/uchime/files/CMakeLists.txt
index 54b0a3ba0d30..a9319293e10b 100644
--- a/sci-biology/uchime/files/CMakeLists.txt
+++ b/sci-biology/uchime/files/CMakeLists.txt
@@ -1,11 +1,12 @@
-cmake_minimum_required(VERSION 2.6)
+cmake_minimum_required(VERSION 2.8.12)
project(UCHIME)
+include(GNUInstallDirs)
+
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -D_FILE_OFFSET_BITS=64 -DUCHIMES=1")
# Simply copy the source files from the mk script
add_executable(uchime
addtargets2.cpp alignchime.cpp alignchimel.cpp alnparams.cpp alpha.cpp alpha2.cpp fractid.cpp getparents.cpp globalalign2.cpp make3way.cpp mx.cpp myutils.cpp path.cpp searchchime.cpp seqdb.cpp setnucmx.cpp sfasta.cpp tracebackbit.cpp uchime_main.cpp usort.cpp viterbifast.cpp writechhit.cpp)
-INSTALL(TARGETS uchime
- DESTINATION bin)
+INSTALL(TARGETS uchime DESTINATION ${CMAKE_INSTALL_BINDIR})
diff --git a/sci-biology/uchime/uchime-4.2.40.ebuild b/sci-biology/uchime/uchime-4.2.40.ebuild
index dd2201547ae0..75827ab3a304 100644
--- a/sci-biology/uchime/uchime-4.2.40.ebuild
+++ b/sci-biology/uchime/uchime-4.2.40.ebuild
@@ -1,18 +1,17 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-
-inherit cmake-utils
+EAPI=7
MY_P="${PN}${PV}_src"
+inherit cmake
DESCRIPTION="Fast, accurate chimera detection"
-HOMEPAGE="http://www.drive5.com/uchime/"
-SRC_URI="http://drive5.com/${PN}/${MY_P}.tar.gz"
+HOMEPAGE="https://www.drive5.com/usearch/manual/uchime_algo.html"
+SRC_URI="https://www.drive5.com/${PN}/${MY_P}.tar.gz"
-SLOT="0"
LICENSE="public-domain"
+SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
IUSE="debug"
@@ -20,6 +19,5 @@ S="${WORKDIR}"/${MY_P}
src_prepare() {
cp "${FILESDIR}"/CMakeLists.txt . || die
-
- cmake-utils_src_prepare
+ cmake_src_prepare
}