summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/wol')
-rw-r--r--net-misc/wol/Manifest1
-rw-r--r--net-misc/wol/metadata.xml16
-rw-r--r--net-misc/wol/wol-0.7.1-r1.ebuild19
3 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/wol/Manifest b/net-misc/wol/Manifest
new file mode 100644
index 000000000000..ebfe810bf668
--- /dev/null
+++ b/net-misc/wol/Manifest
@@ -0,0 +1 @@
+DIST wol-0.7.1.tar.gz 445648 SHA256 e0086c9b9811df2bdf763ec9016dfb1bcb7dba9fa6d7858725b0929069a12622 SHA512 233cbd038633c4b04a22710c04a8349d7706c6b4ff0554b6899ee3309349502a318f6fb05a4ad4c80cd373c362b2ad8818cb52a432d768f569e80f05658615a3 WHIRLPOOL 36f9e9fdfe76846e9f65a2c7e83530532dc24c8dff6fe6f5e30c53659d59be926aaef13e028f23f325564a4d7b43dfbc9759b5ca9d354fb61edcf5ca46cbf7b3
diff --git a/net-misc/wol/metadata.xml b/net-misc/wol/metadata.xml
new file mode 100644
index 000000000000..31f0297e3ce5
--- /dev/null
+++ b/net-misc/wol/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>hwoarang@gentoo.org</email>
+ <name>Markos Chandras</name>
+ </maintainer>
+ <longdescription>
+wol implements Wake On LAN functionality in a small program. It wakes up hardware that is Magic Packet compliant.
+Consider you have a sleeping or turned-off computer and you want to remotely wake him up. Just type
+"wol MAC-ADDRESS" and the host wakes up (OK, it will boot ;-).
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">ahh</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/wol/wol-0.7.1-r1.ebuild b/net-misc/wol/wol-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..cc7d1f428d9e
--- /dev/null
+++ b/net-misc/wol/wol-0.7.1-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Wake up hardware that is Magic Packet compliant"
+HOMEPAGE="http://ahh.sourceforge.net/wol/"
+SRC_URI="mirror://sourceforge/ahh/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm ppc ~ppc64 x86 ~x86-fbsd"
+IUSE="nls"
+
+src_configure() {
+ econf \
+ $(use_enable nls)
+}