summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/htpdate')
-rw-r--r--net-misc/htpdate/Manifest2
-rw-r--r--net-misc/htpdate/files/htpdate.conf12
-rw-r--r--net-misc/htpdate/files/htpdate.init-r121
-rw-r--r--net-misc/htpdate/htpdate-1.0.7.ebuild48
-rw-r--r--net-misc/htpdate/htpdate-1.1.1.ebuild41
-rw-r--r--net-misc/htpdate/metadata.xml8
6 files changed, 132 insertions, 0 deletions
diff --git a/net-misc/htpdate/Manifest b/net-misc/htpdate/Manifest
new file mode 100644
index 000000000000..4212b089ea0d
--- /dev/null
+++ b/net-misc/htpdate/Manifest
@@ -0,0 +1,2 @@
+DIST htpdate-1.0.7.tar.gz 16848 SHA256 ba0b3f7b42306f2e2e146624785f80cc472eac9e7885007df50af0e1a21735c4 SHA512 83408545d1d2cc794f62efaf348e54cc2ce47dfb27815710e92d0c7d34360a581e637ef82424030c8a4fcabcc9a07205518fac08f426b37c7c4519cfa6696360 WHIRLPOOL e2e949d20b8d4afecd6c3c09aefa203417b16a4061e6d2fe05cf5e37d0dc736604ed5e1f0d8c03146eb3b5031ffc3ed8ec3213171513e6140a098bd1d5f268fb
+DIST htpdate-1.1.1.tar.gz 13303 SHA256 6fca5f13e323d4bf8e4a2ae20dfaae527b745b3cf19e9aeccfe2f211e7cc7a7a SHA512 bfc463692b7c4fb962c0b6f34e6063d2506e383490e6d6972b7da3740fbd0b835a07cddd3470bea29f8d2770160fba5f87fd3d768cb27a1f04ea9f5a39522918 WHIRLPOOL 7faa7ce4dd96d48a2a7ddc20a61a7230d9658042f3c9e39229ade41a312d78a0d5827a3348b2671de36fdbcb0aa35873fa5bee6e0c13218e94fbc23f3f2730b7
diff --git a/net-misc/htpdate/files/htpdate.conf b/net-misc/htpdate/files/htpdate.conf
new file mode 100644
index 000000000000..1c7e02decf27
--- /dev/null
+++ b/net-misc/htpdate/files/htpdate.conf
@@ -0,0 +1,12 @@
+# config file for /etc/init.d/htpdate
+
+# Add at least one http server to use:
+#SERVERS="<servername>"
+
+# If you are using a proxy server to connect to the
+# internet comment out the following line and insert the
+# address and port of your proxy server.
+#PROXY="-P <proxy>:<port>"
+
+# Set additional options, see 'man htpdate' for refernce
+HTPDATE_OPTS="-D -s"
diff --git a/net-misc/htpdate/files/htpdate.init-r1 b/net-misc/htpdate/files/htpdate.init-r1
new file mode 100644
index 000000000000..9cf98836786b
--- /dev/null
+++ b/net-misc/htpdate/files/htpdate.init-r1
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+description="Synchronizes local system with time offered by remote webservers over HTTP"
+pidfile="/run/htpdate.pid"
+command="/usr/sbin/htpdate"
+command_args="${HTPDATE_OPTS} ${PROXY} ${SERVERS}"
+
+depend() {
+ need net
+ use dns logger
+}
+
+start_pre() {
+ if [ -z "${SERVERS}" ] ; then
+ eerror "You need to set at least one http server to use in /etc/conf.d/htpdate"
+ return 1
+ fi
+}
diff --git a/net-misc/htpdate/htpdate-1.0.7.ebuild b/net-misc/htpdate/htpdate-1.0.7.ebuild
new file mode 100644
index 000000000000..66514f77b113
--- /dev/null
+++ b/net-misc/htpdate/htpdate-1.0.7.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit readme.gentoo toolchain-funcs unpacker
+
+DESCRIPTION="Synchronize local workstation with time offered by remote webservers"
+HOMEPAGE="http://www.vervest.org/fiki/bin/view/HTP/DownloadC"
+SRC_URI="http://www.vervest.org/htp/archive/c/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~mips ppc ~ppc64 s390 sh x86 ~amd64-linux ~x86-linux"
+
+DEPEND=""
+RDEPEND=""
+
+DOC_CONTENTS="If you would like to run htpdate as a daemon, set
+appropriate http servers in /etc/conf.d/htpdate!"
+
+src_unpack() {
+ default
+
+ cd "${S}" || die "change directory to ${S} failed"
+ unpacker htpdate.8.gz
+}
+
+src_prepare() {
+ # Use more standard adjtimex() to fix uClibc builds.
+ sed -i 's:ntp_adjtime:adjtimex:g' htpdate.[8c] || die
+}
+
+src_compile() {
+ emake CFLAGS="-Wall ${CFLAGS} ${LDFLAGS}" CC="$(tc-getCC)"
+}
+
+src_install() {
+ dosbin htpdate
+ doman htpdate.8
+ dodoc README Changelog
+
+ newconfd "${FILESDIR}"/htpdate.conf htpdate
+ newinitd "${FILESDIR}"/htpdate.init-r1 htpdate
+
+ readme.gentoo_create_doc
+}
diff --git a/net-misc/htpdate/htpdate-1.1.1.ebuild b/net-misc/htpdate/htpdate-1.1.1.ebuild
new file mode 100644
index 000000000000..d70048232eea
--- /dev/null
+++ b/net-misc/htpdate/htpdate-1.1.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit readme.gentoo toolchain-funcs unpacker
+
+DESCRIPTION="Synchronize local workstation with time offered by remote webservers"
+HOMEPAGE="http://www.vervest.org/fiki/bin/view/HTP/DownloadC"
+SRC_URI="http://www.vervest.org/htp/archive/c/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND=""
+RDEPEND=""
+
+DOC_CONTENTS="If you would like to run htpdate as a daemon, set
+appropriate http servers in /etc/conf.d/htpdate!"
+
+src_prepare() {
+ # Use more standard adjtimex() to fix uClibc builds.
+ sed -i 's:ntp_adjtime:adjtimex:g' htpdate.[8c] || die
+}
+
+src_compile() {
+ emake CFLAGS="-Wall ${CFLAGS} ${LDFLAGS}" CC="$(tc-getCC)"
+}
+
+src_install() {
+ dosbin htpdate
+ doman htpdate.8
+ dodoc README Changelog
+
+ newconfd "${FILESDIR}"/htpdate.conf htpdate
+ newinitd "${FILESDIR}"/htpdate.init-r1 htpdate
+
+ readme.gentoo_create_doc
+}
diff --git a/net-misc/htpdate/metadata.xml b/net-misc/htpdate/metadata.xml
new file mode 100644
index 000000000000..8ad2b4de9bf4
--- /dev/null
+++ b/net-misc/htpdate/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>nullishzero@gentoo.org</email>
+ <name>Pavel Kazakov</name>
+ </maintainer>
+</pkgmetadata>