summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/nodejs/nodejs-12.10.0.ebuild')
-rw-r--r--net-libs/nodejs/nodejs-12.10.0.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/net-libs/nodejs/nodejs-12.10.0.ebuild b/net-libs/nodejs/nodejs-12.10.0.ebuild
index 7cc1a7dd9a62..7a072e08f8c1 100644
--- a/net-libs/nodejs/nodejs-12.10.0.ebuild
+++ b/net-libs/nodejs/nodejs-12.10.0.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads"
-inherit bash-completion-r1 flag-o-matic pax-utils python-any-r1 toolchain-funcs
+inherit bash-completion-r1 flag-o-matic pax-utils python-any-r1 toolchain-funcs xdg-utils
DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
HOMEPAGE="https://nodejs.org/"
@@ -90,6 +90,8 @@ src_prepare() {
}
src_configure() {
+ xdg_environment_reset
+
local myconf=(
--shared-cares --shared-http-parser --shared-libuv --shared-nghttp2
--shared-zlib