summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/lftp/lftp-9999.ebuild')
-rw-r--r--net-ftp/lftp/lftp-9999.ebuild28
1 files changed, 15 insertions, 13 deletions
diff --git a/net-ftp/lftp/lftp-9999.ebuild b/net-ftp/lftp/lftp-9999.ebuild
index 4eeb8cb7874b..a5e731f6531e 100644
--- a/net-ftp/lftp/lftp-9999.ebuild
+++ b/net-ftp/lftp/lftp-9999.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
inherit autotools git-r3 libtool xdg-utils
DESCRIPTION="A sophisticated ftp/sftp/http/https/torrent client and file transfer program"
@@ -10,7 +11,6 @@ EGIT_REPO_URI="https://github.com/lavv17/lftp"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS=""
IUSE="convert-mozilla-cookies +gnutls idn nls socks5 +ssl verify-file"
RDEPEND="
@@ -36,10 +36,9 @@ RDEPEND="
DEPEND="
${RDEPEND}
- dev-libs/gnulib
=dev-build/libtool-2*
app-arch/xz-utils
- nls? ( >=sys-devel/gettext-0.19 )
+ nls? ( >=sys-devel/gettext-0.21 )
virtual/pkgconfig
"
@@ -47,14 +46,18 @@ DOCS=(
BUGS ChangeLog FAQ FEATURES MIRRORS NEWS README README.debug-levels
README.dnssec README.modules THANKS TODO
)
+
PATCHES=(
- "${FILESDIR}"/${PN}-4.5.5-am_config_header.patch
+ "${FILESDIR}"/${PN}-4.0.2.91-lafile.patch
+ "${FILESDIR}"/${PN}-4.7.5-libdir-additional.patch
"${FILESDIR}"/${PN}-4.7.5-libdir-expat.patch
"${FILESDIR}"/${PN}-4.8.2-libdir-configure.patch
"${FILESDIR}"/${PN}-4.8.2-libdir-libidn2.patch
"${FILESDIR}"/${PN}-4.8.2-libdir-openssl.patch
"${FILESDIR}"/${PN}-4.8.2-libdir-zlib.patch
"${FILESDIR}"/${PN}-4.9.1-libdir-readline.patch
+ "${FILESDIR}"/${PN}-4.9.2-socks.patch
+ "${FILESDIR}"/${PN}-4.9.3-gnulib.patch
)
# Gnulib false positive #900064
@@ -66,12 +69,12 @@ src_prepare() {
# bug #875692
sed -e '/#include/s/cmath/math.h/' -i trio/*.c || die
- gnulib-tool --update || die
-
- chmod +x build-aux/git-version-gen || die
-
eautoreconf
+
elibtoolize # for Darwin bundles
+
+ # bug #536036
+ printf 'set fish:auto-confirm no\nset sftp:auto-confirm no\n' >> ${PN}.conf || die
}
src_configure() {
@@ -81,7 +84,7 @@ src_configure() {
$(use_with socks5 socksdante "${EPREFIX}"/usr) \
$(usex ssl "$(use_with !gnutls openssl "${EPREFIX}"/usr)" '--without-openssl') \
$(usex ssl "$(use_with gnutls)" '--without-gnutls') \
- --enable-ipv6
+ --enable-ipv6 \
--enable-packager-mode \
--sysconfdir="${EPREFIX}"/etc/${PN} \
--with-modules \
@@ -90,8 +93,7 @@ src_configure() {
}
src_install() {
- # FIXME: MKDIR_P is not getting picked up in po/Makefile
- emake DESTDIR="${D}" mkdir_p="mkdir -p" install
+ default
local script
for script in {convert-mozilla-cookies,verify-file}; do