summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/gftp/gftp-2.9.1b.ebuild')
-rw-r--r--net-ftp/gftp/gftp-2.9.1b.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-ftp/gftp/gftp-2.9.1b.ebuild b/net-ftp/gftp/gftp-2.9.1b.ebuild
new file mode 100644
index 000000000000..4cbd3b794981
--- /dev/null
+++ b/net-ftp/gftp/gftp-2.9.1b.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2
+
+DESCRIPTION="a free multithreaded file transfer client"
+SRC_URI="https://github.com/masneyb/gftp/releases/download/${PV}/${P}.tar.xz"
+HOMEPAGE="https://github.com/masneyb/gftp"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="gtk ssl"
+
+RDEPEND="
+ dev-libs/glib:2
+ sys-libs/ncurses:0=
+ sys-libs/readline:0
+ gtk? ( x11-libs/gtk+:2 )
+ ssl? ( dev-libs/openssl:0= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable gtk gtkport) \
+ $(use_enable ssl)
+}
+
+src_install() {
+ gnome2_src_install
+ dodoc docs/USERS-GUIDE
+}