summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/ibp/ibp-0.21.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/media-radio/ibp/ibp-0.21.ebuild b/media-radio/ibp/ibp-0.21.ebuild
deleted file mode 100644
index 9777e82215b5..000000000000
--- a/media-radio/ibp/ibp-0.21.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="4"
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Shows currently transmitting beacons of the International Beacon Project (IBP)"
-HOMEPAGE="http://wwwhome.cs.utwente.nl/~ptdeboer/ham/${PN}.html"
-SRC_URI="http://wwwhome.cs.utwente.nl/~ptdeboer/ham/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="X"
-
-RDEPEND="sys-libs/ncurses
- X? ( x11-libs/libX11 )"
-DEPEND="${RDEPEND}
- X? ( x11-misc/imake )"
-
-src_prepare() {
- # respect CFLAGS if built without USE=X
- sed -i -e "s/= -D/+= -D/" Makefile || die
-}
-
-src_configure() {
- if use X ;then
- xmkmf || die
- fi
-}
-
-src_compile() {
- if use X ; then
- emake \
- CC="$(tc-getCC)" \
- LOCAL_LDFLAGS="${LDFLAGS}" \
- CDEBUGFLAGS="${CFLAGS}"
- else
- emake CC="$(tc-getCC)"
- fi
-}
-
-src_install() {
- dobin ${PN}
- doman ${PN}.1
-}