summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/textmaze/textmaze-1.2.ebuild')
-rw-r--r--games-puzzle/textmaze/textmaze-1.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/games-puzzle/textmaze/textmaze-1.2.ebuild b/games-puzzle/textmaze/textmaze-1.2.ebuild
new file mode 100644
index 000000000000..11063d9d01d0
--- /dev/null
+++ b/games-puzzle/textmaze/textmaze-1.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit games
+
+MY_P=${PN}_v${PV}
+DESCRIPTION="An ncurses-based maze solving game written in Perl"
+HOMEPAGE="http://robobunny.com/projects/textmaze/html/"
+SRC_URI="http://www.robobunny.com/projects/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="dev-perl/Curses"
+
+S=${WORKDIR}/TextMaze
+
+src_prepare() {
+ sed -i \
+ -e "s#/usr/local/bin/perl#/usr/bin/perl#" \
+ textmaze || die
+}
+
+src_install() {
+ dogamesbin textmaze
+ dodoc CHANGES README
+ prepgamesdirs
+}