summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/krystaldrop/krystaldrop-0.7.2.ebuild')
-rw-r--r--games-puzzle/krystaldrop/krystaldrop-0.7.2.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/games-puzzle/krystaldrop/krystaldrop-0.7.2.ebuild b/games-puzzle/krystaldrop/krystaldrop-0.7.2.ebuild
index 9bda85a8bf3f..9e173dde092c 100644
--- a/games-puzzle/krystaldrop/krystaldrop-0.7.2.ebuild
+++ b/games-puzzle/krystaldrop/krystaldrop-0.7.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=4
inherit eutils games
DESCRIPTION="Free clone of an excellent NeoGeo puzzle game, Magical Drop"
@@ -16,12 +16,12 @@ KEYWORDS="amd64 x86"
IUSE=""
DEPEND="virtual/opengl
- media-libs/libsdl[opengl,video]
- media-libs/sdl-image[jpeg,png]
+ media-libs/libsdl
+ media-libs/sdl-image
media-libs/sdl-mixer
media-libs/sdl-ttf
dev-libs/libxml2"
-RDEPEND=${DEPEND}
+RDEPEND="${DEPEND}"
S=${WORKDIR}/${PN}
@@ -39,13 +39,14 @@ src_prepare() {
sed -i \
-e "/^EXEDIR:=/ s|$|/bin|" \
- -e "/^INSTALL_PREFIX:=/ s|$|${D}|" \
- Makefile || die
+ -e "/^INSTALL_PREFIX:=/ s|$|${D}|" Makefile \
+ || die "sed Makefile failed"
# fix the high score location
sed -i \
-e "s:BINDIR:\"${GAMES_STATEDIR}/${PN}\":" \
- Sources/KrystalDrop/Controller/HighScoresController.cpp || die
+ Sources/KrystalDrop/Controller/HighScoresController.cpp \
+ || die "sed HighScoresController.cpp failed"
}
src_install() {