summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/minetest')
-rw-r--r--games-action/minetest/files/minetest-5.4.1-gcc11.patch21
-rw-r--r--games-action/minetest/files/minetest-5.5.0-bundled_luabitop.patch17
2 files changed, 0 insertions, 38 deletions
diff --git a/games-action/minetest/files/minetest-5.4.1-gcc11.patch b/games-action/minetest/files/minetest-5.4.1-gcc11.patch
deleted file mode 100644
index bb37cdf31e07..000000000000
--- a/games-action/minetest/files/minetest-5.4.1-gcc11.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From 7c2826cbc0f36027d4a9781f433150d1c5d0d03f Mon Sep 17 00:00:00 2001
-From: lhofhansl <larsh@apache.org>
-Date: Thu, 6 May 2021 10:24:30 -0700
-Subject: [PATCH] Fix build for newer versions of GCC (#11246)
-
----
- src/clientiface.h | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/clientiface.h b/src/clientiface.h
-index cc5292b71bf9..dfd97674137c 100644
---- a/src/clientiface.h
-+++ b/src/clientiface.h
-@@ -31,6 +31,7 @@ with this program; if not, write to the Free Software Foundation, Inc.,
- #include <list>
- #include <vector>
- #include <set>
-+#include <memory>
- #include <mutex>
-
- class MapBlock;
diff --git a/games-action/minetest/files/minetest-5.5.0-bundled_luabitop.patch b/games-action/minetest/files/minetest-5.5.0-bundled_luabitop.patch
deleted file mode 100644
index 5006ddd499b6..000000000000
--- a/games-action/minetest/files/minetest-5.5.0-bundled_luabitop.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-When built against PUC Lua, minetest binaries get linked against
-a customised version of LuaBitOp which then gets installed
-as /usr/$(get_libdir)/libbitop.so. This violates the policies of both
-Gentoo (unversioned shared library) and Lua itself (compiled extensions
-should be installed into implementation-specific directories rather than
-top-level libdir, and I'm pretty sure linking against such extensions
-is a no-no). Switching to system dev-lua/LuaBitOp will require work
-so just make the customised version static for now.
-
---- a/lib/bitop/CMakeLists.txt
-+++ b/lib/bitop/CMakeLists.txt
-@@ -1,4 +1,4 @@
--add_library(bitop bit.c)
-+add_library(bitop STATIC bit.c)
- target_link_libraries(bitop)
-
- include_directories(${LUA_INCLUDE_DIR})