summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/revtex')
-rw-r--r--dev-tex/revtex/Manifest2
-rw-r--r--dev-tex/revtex/metadata.xml7
-rw-r--r--dev-tex/revtex/revtex-4.1_p2-r1.ebuild43
-rw-r--r--dev-tex/revtex/revtex-4.ebuild39
4 files changed, 91 insertions, 0 deletions
diff --git a/dev-tex/revtex/Manifest b/dev-tex/revtex/Manifest
new file mode 100644
index 000000000000..22b170781c3e
--- /dev/null
+++ b/dev-tex/revtex/Manifest
@@ -0,0 +1,2 @@
+DIST revtex-4.1_p2.zip 4168885 SHA256 64b5b8cf97df6a8ff6c24adcd827cf4028d5b984cebc84f06e4b9d1f7f99a08a SHA512 df093543af1274fd218ee9d430da76aff07174d122b446abef1bf0c0333e154bd2c4e1db06dd178c82a0f1cdf83355faffa2dee18f19d18cd7e848a06b748d2d WHIRLPOOL 179404b043e087c281fa4c33be58c46a43b9d31cecc509b55d60042571b4db0bff135d07b72a6142474872b2c24e6c2b5b3311e8327ee44d79b56cc9fa2a872e
+DIST revtex4.zip 957277 SHA256 0f0bc5a635209b8aab0856a8f97e5eb4ca8105014143383234db823bbb3028c2 SHA512 816960d3f12dbdac0d9fb762ab2fff4e88fc0d436bf70101f172440b0eac90686517a3f857a6cf072b0344273b8eb3b4dd3c7c5d33c927e75183989cf14263fc WHIRLPOOL b6c4af7d53307055318a42a2839dbfec315135e379cf279d92af235f5fbdccf3373af1046b61c91a74fa8af2960deda500313edad9486a2943bc27e6e3fca759
diff --git a/dev-tex/revtex/metadata.xml b/dev-tex/revtex/metadata.xml
new file mode 100644
index 000000000000..64ebb139fe48
--- /dev/null
+++ b/dev-tex/revtex/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>tex</herd>
+<herd>sci</herd>
+<maintainer><email>dilfridge@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/dev-tex/revtex/revtex-4.1_p2-r1.ebuild b/dev-tex/revtex/revtex-4.1_p2-r1.ebuild
new file mode 100644
index 000000000000..3b674cbe4882
--- /dev/null
+++ b/dev-tex/revtex/revtex-4.1_p2-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit versionator latex-package
+
+MY_P="${PN}$(version_format_string '$1-$2')"
+
+DESCRIPTION="LaTeX2e macros for journals of the American Physical Society and the American Institute of Physics"
+HOMEPAGE="http://authors.aps.org/revtex4/"
+
+SRC_URI="http://authors.aps.org/revtex4/${MY_P}.zip -> ${P}.zip"
+
+LICENSE="LPPL-1.3c"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND=">=dev-texlive/texlive-latex-2012"
+DEPEND="app-arch/unzip"
+
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+TEXMF=/usr/share/texmf-site
+
+src_unpack() {
+ default
+ cd "${S}"
+ unzip -o -j "${S}/${MY_P}-tds.zip"
+}
+
+src_install() {
+ latex-package_src_install
+
+ # we need the revtex-specific rtx files in the same dir as the class files
+ insinto ${TEXMF}/tex/latex/${PN}
+ for i in `find . -maxdepth 1 -type f -name "*.rtx"` ; do
+ doins $i || die "doins $i failed"
+ done
+}
diff --git a/dev-tex/revtex/revtex-4.ebuild b/dev-tex/revtex/revtex-4.ebuild
new file mode 100644
index 000000000000..e018e15a2d2d
--- /dev/null
+++ b/dev-tex/revtex/revtex-4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit latex-package
+
+DESCRIPTION="LaTeX2e macros for journals of the American Physical Society and the American Institute of Physics"
+HOMEPAGE="http://authors.aps.org/revtex4/"
+
+SRC_URI="http://publish.aps.org/files/revtex/4/revtex4.zip"
+
+LICENSE="LPPL-1.3c"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-texlive/texlive-latex-2012"
+DEPEND="app-arch/unzip"
+
+IUSE=""
+
+S="${WORKDIR}/revtex4/src"
+
+TEXMF=/usr/share/texmf-site
+
+src_install() {
+ latex-package_src_install
+
+ # we need the revtex-specific rtx files in the same dir as the class files
+ insinto ${TEXMF}/tex/latex/${PN}
+ for i in `find . -maxdepth 1 -type f -name "*.rtx"` ; do
+ doins $i || die "doins $i failed"
+ done
+
+ # remove duplicate docu files to allow concurrent install with revtex-4.1
+ rm -fv "${ED}/${TEXMF}/doc/latex/revtex/"{ltxdocext.pdf,ltxgrid.pdf,ltxutil.pdf,ltxutil.dvi}
+ rm -fv "${ED}/usr/share/doc/${P}/"{textcase.dvi,revtex4.dvi,ltxgrid.dvi,ltxdocext.dvi}
+}