summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/fast-stemmer/fast-stemmer-1.0.2-r4.ebuild')
-rw-r--r--dev-ruby/fast-stemmer/fast-stemmer-1.0.2-r4.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/fast-stemmer/fast-stemmer-1.0.2-r4.ebuild b/dev-ruby/fast-stemmer/fast-stemmer-1.0.2-r4.ebuild
new file mode 100644
index 000000000000..7840a1559e99
--- /dev/null
+++ b/dev-ruby/fast-stemmer/fast-stemmer-1.0.2-r4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="README"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple wrapper around multithreaded Porter stemming algorithm"
+HOMEPAGE="https://github.com/romanbsd/fast-stemmer"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE=""
+
+all_ruby_prepare() {
+ rm ext/Makefile || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S testrb-2 test/fast_stemmer_test.rb || die
+}