summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycpio')
-rw-r--r--dev-python/pycpio/Manifest1
-rw-r--r--dev-python/pycpio/pycpio-1.4.0.ebuild30
-rw-r--r--dev-python/pycpio/pycpio-9999.ebuild7
3 files changed, 36 insertions, 2 deletions
diff --git a/dev-python/pycpio/Manifest b/dev-python/pycpio/Manifest
index 62898fa7d161..2fa5700345d9 100644
--- a/dev-python/pycpio/Manifest
+++ b/dev-python/pycpio/Manifest
@@ -1 +1,2 @@
DIST pycpio-1.3.2.tar.gz 22449 BLAKE2B 9f183ccb44552295c1ddf83102865b59f00f387302cbfcdf4cf226bd72a7e6b49883db8c0fece50904c4dc4891f8ee2b513e3192d95f74dd673e3c71e13817dc SHA512 d5e7f4f59e91944bf3c49cb3da79e34b11167a39374036906a3c1fb2230992ec31c1c51880cf26ef3682a58a5082627635576bd697a4b972edd9d62ade7e9130
+DIST pycpio-1.4.0.gh.tar.gz 22518 BLAKE2B 192ce37d9ffa1e049ff7f11494a01295f28efbb4cca08b0a7316ea130a4c5d8edf51101a2e07276d4a24fdbca01644082489cb531ad049ad8ce4c801e90d6add SHA512 3fc30159ea14ec16ca30031df2e1624e92b3815829e00eedeccb41b3fb224c17d1af18d2d544ccf677094f6ab5c7d76407bc8d316c359fe8620ab350aed080e1
diff --git a/dev-python/pycpio/pycpio-1.4.0.ebuild b/dev-python/pycpio/pycpio-1.4.0.ebuild
new file mode 100644
index 000000000000..0ffa2f141e23
--- /dev/null
+++ b/dev-python/pycpio/pycpio-1.4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python CPIO library"
+HOMEPAGE="https://github.com/desultory/pycpio/"
+SRC_URI="
+ https://github.com/desultory/pycpio/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ >=dev-python/zenlib-2.3.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest tests
+}
diff --git a/dev-python/pycpio/pycpio-9999.ebuild b/dev-python/pycpio/pycpio-9999.ebuild
index 140af15820ae..2f01756bb307 100644
--- a/dev-python/pycpio/pycpio-9999.ebuild
+++ b/dev-python/pycpio/pycpio-9999.ebuild
@@ -5,6 +5,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{11..12} )
+
inherit distutils-r1 git-r3
DESCRIPTION="Python CPIO library"
@@ -14,10 +15,12 @@ EGIT_REPO_URI="https://github.com/desultory/${PN}"
LICENSE="GPL-2"
SLOT="0"
-RDEPEND=">=dev-python/zenlib-9999[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/zenlib-2.3.0[${PYTHON_USEDEP}]
+"
distutils_enable_tests unittest
python_test() {
- eunittest tests/
+ eunittest tests
}