summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hcloud-python')
-rw-r--r--dev-python/hcloud-python/Manifest1
-rw-r--r--dev-python/hcloud-python/hcloud-python-1.18.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/hcloud-python/Manifest b/dev-python/hcloud-python/Manifest
index f20b66667b40..885b0a11411e 100644
--- a/dev-python/hcloud-python/Manifest
+++ b/dev-python/hcloud-python/Manifest
@@ -1 +1,2 @@
DIST hcloud-python-1.17.0.gh.tar.gz 98069 BLAKE2B b8fb2f1c4a3d139225a19599f956a845789872642bc62ec0434f5393e90f5ef64226b6363eeae0b3312084312aac4ddbe77e6e134b0502783e72568f23a71ee5 SHA512 829972585b5fe61aaaa2ee5294c97e6ad4a913229e8d87cec8e00d61480a780682b4eb75e2b9da5962bdb3dfda15b0a81afa74383be874e381a5f8e1a27d7014
+DIST hcloud-python-1.18.0.gh.tar.gz 99047 BLAKE2B c32b048653bea1910ed8a82d0e08603a154dc89208c0cf8b9e046078277460fedffe6568c7c3cf56a8408bb0423d38464c4fd57dded4523886560823e3ee65da SHA512 8339b5da4df7f5e1f38fbd7a3f205387bfd7a65a7c4eaa757c4c35056b70c06230fe9b8a597b54bac082af975184bd5ef33a6e2747b60a67cc34d6771435452c
diff --git a/dev-python/hcloud-python/hcloud-python-1.18.0.ebuild b/dev-python/hcloud-python/hcloud-python-1.18.0.ebuild
new file mode 100644
index 000000000000..2fc96fa6b76e
--- /dev/null
+++ b/dev-python/hcloud-python/hcloud-python-1.18.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Official Hetzner Cloud python library"
+HOMEPAGE="https://github.com/hetznercloud/hcloud-python"
+SRC_URI="
+ https://github.com/hetznercloud/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples"
+
+RDEPEND="
+ >=dev-python/future-0.17.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.7.5[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ # Integration tests need docker:
+ # https://github.com/hetznercloud/hcloud-python/blob/master/.travis.yml#L16
+ epytest --ignore tests/integration
+}