summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/phpDocumentor/phpDocumentor-2.8.2.ebuild')
-rw-r--r--dev-php/phpDocumentor/phpDocumentor-2.8.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-php/phpDocumentor/phpDocumentor-2.8.2.ebuild b/dev-php/phpDocumentor/phpDocumentor-2.8.2.ebuild
new file mode 100644
index 000000000000..d1b4b3af4491
--- /dev/null
+++ b/dev-php/phpDocumentor/phpDocumentor-2.8.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="The phpDocumentor package provides automatic documenting of php api directly from the source"
+HOMEPAGE="http://phpdoc.org"
+SRC_URI="https://github.com/${PN}/${PN}2/releases/download/v${PV}/${PN}.phar -> ${P}.phar"
+
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+# block old version that provides the same binary
+DEPEND="!dev-php/PEAR-PhpDocumentor"
+RDEPEND="media-gfx/graphviz
+ dev-lang/php:*[cli,iconv,intl,phar,xmlreader,xslt]"
+S="${WORKDIR}"
+
+src_unpack() { :; }
+
+src_install() {
+ insinto /usr/share/php/${PN}
+ insopts -m755
+ newins "${DISTDIR}/${P}.phar" ${PN}.phar
+ dosym /usr/share/php/${PN}/${PN}.phar /usr/bin/phpdoc
+}