summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/tinyxml2')
-rw-r--r--dev-libs/tinyxml2/Manifest1
-rw-r--r--dev-libs/tinyxml2/metadata.xml11
-rw-r--r--dev-libs/tinyxml2/tinyxml2-9.0.0.ebuild22
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/tinyxml2/Manifest b/dev-libs/tinyxml2/Manifest
new file mode 100644
index 000000000000..ad78643036ad
--- /dev/null
+++ b/dev-libs/tinyxml2/Manifest
@@ -0,0 +1 @@
+DIST tinyxml2-9.0.0.tar.gz 619734 BLAKE2B 9a7bb8b8158417aa505e3d9fcc246b0bede52d6d4d5ff1b5cee891c2b72d1ee43d00ccea001ac24500f52c36320994b3446f3898ab2be1997940dbff526bc78e SHA512 9c5ce8131984690df302ca3e32314573b137180ed522c92fd631692979c942372a28f697fdb3d5e56bcf2d3dc596262b724d088153f3e1d721c9536f2a883367
diff --git a/dev-libs/tinyxml2/metadata.xml b/dev-libs/tinyxml2/metadata.xml
new file mode 100644
index 000000000000..af9598a7417c
--- /dev/null
+++ b/dev-libs/tinyxml2/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>media-video@gentoo.org</email>
+ <name>Gentoo Video project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">leethomason/tinyxml2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-libs/tinyxml2/tinyxml2-9.0.0.ebuild b/dev-libs/tinyxml2/tinyxml2-9.0.0.ebuild
new file mode 100644
index 000000000000..007b65ac09c2
--- /dev/null
+++ b/dev-libs/tinyxml2/tinyxml2-9.0.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+DESCRIPTION="A simple, small, efficient, C++ XML parser"
+HOMEPAGE="http://www.grinninglizard.com/tinyxml2/ https://github.com/leethomason/tinyxml2/"
+SRC_URI="https://github.com/leethomason/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0/9"
+KEYWORDS="amd64 arm arm64 ~hppa ~ppc64 ~riscv sparc x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+ local mycmakeargs=( -DBUILD_TESTING=$(usex test) )
+ cmake_src_configure
+}