summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/algol68g/Manifest1
-rw-r--r--dev-lang/algol68g/algol68g-3.5.7.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-lang/algol68g/Manifest b/dev-lang/algol68g/Manifest
index 1afab12f0668..937e0e1110b2 100644
--- a/dev-lang/algol68g/Manifest
+++ b/dev-lang/algol68g/Manifest
@@ -1,3 +1,4 @@
DIST algol68g-3.5.4.tar.gz 664208 BLAKE2B b8e2bcc53cf3cc7254da37f1d5655ddc4f79564c51608fea374da25bc828c34056284f2a48e4ada92202f866c38326c1323aa9803bbbb0be22d3a682767c24fa SHA512 0cedce2c2cb4c8d7de91ef022ade38c2040d8fcd02c747226721a016f1c5ae9a9249314370ac6466be2fdba34f7602ab0954e05dbf20d7af1e68a04059270a5c
DIST algol68g-3.5.5.tar.gz 664205 BLAKE2B 1ac99c1723e45ff69a72592c0209716409c35ce208e79682ed77a972b08cab49b78b735f1b585640c9a8b5d59853cafb601d8a049bc33bfa42f6a37c93848285 SHA512 5c671e1b7f90a6a0197afd0efdae737d409d0db98b4f62e2a958ecbec5d731cb68896e8c14e975d4d569e399a79ee12be3269c6ab2e9c6a34f2cb6d9a1e5a273
DIST algol68g-3.5.6.tar.gz 664375 BLAKE2B ccb6cd26ca700191ff09e81359fc7a72b803213519d8b835fbee70e8d403915752f26c9b4cd9bf6cf5675879c9a90613bdb971302167a11452632380335d21dc SHA512 b737e20fdab0c7b8918a400cc3923ee5d265cb732a240e0fdcdc9d0343e46aa68d852b19e9feb4659fe5ea5b86f2d6542ebf59b4d8ea356f63c3c9b4520bf3a9
+DIST algol68g-3.5.7.tar.gz 664353 BLAKE2B 109a94c6e8996d71634187bafaf33ce6be40c054dcd62a5cb40a5197ad645a3f8769b3596504206aeccd4769aa80af263ad763b115171db73e3255b5e64347a8 SHA512 05a3d51cffb918d0e61d8692da83905190d3c52079acb3bcad2c49e8fa9dcc9ab433a830486db337ff28c540b128795d5af876d70ad778c72426549c1a6116d9
diff --git a/dev-lang/algol68g/algol68g-3.5.7.ebuild b/dev-lang/algol68g/algol68g-3.5.7.ebuild
new file mode 100644
index 000000000000..6689c5616025
--- /dev/null
+++ b/dev-lang/algol68g/algol68g-3.5.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Algol 68 Genie compiler-interpreter"
+HOMEPAGE="https://jmvdveer.home.xs4all.nl/en.algol-68-genie.html"
+SRC_URI="https://jmvdveer.home.xs4all.nl/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+curl +gsl +mpfr +ncurses plotutils postgres +readline"
+
+RDEPEND="
+ curl? ( net-misc/curl )
+ gsl? ( sci-libs/gsl:= )
+ mpfr? ( dev-libs/mpfr:= )
+ plotutils? ( media-libs/plotutils )
+ postgres? ( dev-db/postgresql:* )
+ readline? ( sys-libs/readline:= )
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+PATCHES=( "${FILESDIR}/${PN}-3.3.21-configure-implicit.patch" )
+
+src_configure() {
+ local -a myconf=(
+ $(use_enable curl)
+ $(use_enable gsl)
+ $(use_enable mpfr)
+ $(use_enable ncurses curses)
+ $(use_enable plotutils)
+ $(use_enable postgres postgresql)
+ $(use_enable readline)
+ $(use_with ncurses)
+ )
+ econf "${myconf[@]}"
+}