summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/gforth/gforth-0.7.3-r1.ebuild')
-rw-r--r--dev-lang/gforth/gforth-0.7.3-r1.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/dev-lang/gforth/gforth-0.7.3-r1.ebuild b/dev-lang/gforth/gforth-0.7.3-r1.ebuild
index 01598f0f239e..ddf2c89a40a8 100644
--- a/dev-lang/gforth/gforth-0.7.3-r1.ebuild
+++ b/dev-lang/gforth/gforth-0.7.3-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit elisp-common eutils
+inherit elisp-common
DESCRIPTION="GNU Forth is a fast and portable implementation of the ANSI Forth language"
HOMEPAGE="https://www.gnu.org/software/gforth"
@@ -22,8 +22,18 @@ SITEFILE="50${PN}-gentoo.el"
PATCHES=(
"${FILESDIR}"/${PN}-0.7.0-make-elc.patch
+ "${FILESDIR}"/${PN}-0.7.3-rdynamic.patch
+ "${FILESDIR}"/${PN}-0.7.3-rdynamic-auto.patch
)
+src_prepare() {
+ default
+
+ # We patches both configure and configure.ac.
+ # Avoid reruining aclocal.
+ touch aclocal.m4 configure || die
+}
+
src_configure() {
econf \
$(use emacs || echo "--without-lispdir") \