summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/boot-bin')
-rw-r--r--dev-java/boot-bin/Manifest3
-rw-r--r--dev-java/boot-bin/boot-bin-2.8.3.ebuild75
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-java/boot-bin/Manifest b/dev-java/boot-bin/Manifest
index 3c81177a126c..ef394a4f8cef 100644
--- a/dev-java/boot-bin/Manifest
+++ b/dev-java/boot-bin/Manifest
@@ -1,3 +1,6 @@
DIST boot-2.7.1-CHANGES.md 20380 BLAKE2B 84a57834b78b752b6be051aa9513ad3360cc81b1311248892b3f61760c181a2c53083da8c61eeae2930b2501b95b71dd74bfededa2325806a83abbb0ef0f35e3 SHA512 5f8b9866dcb5e784caee89c7a0569d6a2392cda19aa498d15eaa8d4ea054900bdc0dff950ca60f6c62f0cd262373a3cd0760c755b805d952bc96838de135aeb8
DIST boot-2.7.1-README.md 16071 BLAKE2B de0f5168f1b4151ffc76bf02343a1d965ba418e90255d04ef8c6c0c30e32d1927042ed24d1e5e1e6dad3b9dc0e893bf7656a3cfc279f6e690a5c7587a3930897 SHA512 395b6fec79bd1299f4d84fda4ba3d0db0b54c9c591c7ffd2c3c0f239f5f1bade31bf6eb1b924d6e58775fb6d412417d251d77356698d54c93c3ee31b64c9652a
DIST boot-2.7.1.jar 8388320 BLAKE2B a5af7ee5468cd6db1c955fd7a1726da6bc370ff8fb2b38312c42b9b6577c9605cfd472f86878c8706e50a1523f9e8789e7b92aa7244f2ce0450b7447cd8d5aa8 SHA512 d8101ba2c3a2bdec655f0fcea95a3cb33aee90c9471f6cd31f465c3716cb3f6d9027b7ec0c1c7cd277f8b43cbc0fd69d2e164fa33b112bba94d4d3245caafb3c
+DIST boot-2.8.3-CHANGES.md 28286 BLAKE2B 56ce0ba83292d1b0a9b22b34e3ac89a4f203ff7b20b3a9a0ca092e4594cb8430574d04ff15ec50dc431f4a32ebbcbe2651010abc48c46a241fff5147d1449297 SHA512 cab01416dcbd642953fa32ae5d8255722f61860752a32e7a4a55f0d5730363e305c5549e63777e3e032f2d098864cfa16b62889c66fe9aa481778ad7a0249e80
+DIST boot-2.8.3-README.md 19164 BLAKE2B cb2d63e332d427cd235868f9b25aa5b7baaa41ebbf1447c029019e2d4aa872eed26e79c027f06b201e21e0a1522d42fed57bf5eae5de683baf4a62e2c10b739a SHA512 2557f8ae6893ae6f3c576e8325f11edac5e4e91c45e3864957784092e8154aaa30f1a5de8acb52bb90e7c3ad034f2e9703e4b5aac2d621cbd885e8bbb102cc04
+DIST boot-2.8.3.jar 20940394 BLAKE2B 398264e467dc14c7df49dd75e4197ebd755e1afdc6ae8877de30cd72d35c0bf56a83b64573ec3aa976ae63fcffe9c371b0789bc0f95e43bbb509ff19cc305ee9 SHA512 039c8ed3320871a1227240ad8d0aac07cbb41e65096d71b9547733c49f02febff6ac5ed15cda744c7fbc0ee4830908597f0c3c8288d4d059c603057db24bd1db
diff --git a/dev-java/boot-bin/boot-bin-2.8.3.ebuild b/dev-java/boot-bin/boot-bin-2.8.3.ebuild
new file mode 100644
index 000000000000..03e79137c50c
--- /dev/null
+++ b/dev-java/boot-bin/boot-bin-2.8.3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit java-pkg-2
+
+MY_PN="${PN%-bin}"
+MY_PNV="${MY_PN}-${PV}"
+GITHUB_USER="boot-clj"
+
+DESCRIPTION="Build tooling for Clojure"
+HOMEPAGE="https://boot-clj.com/"
+SRC_URI="
+ https://github.com/${GITHUB_USER}/${MY_PN}/releases/download/${PV}/${MY_PN}.jar -> ${MY_PNV}.jar
+ https://raw.githubusercontent.com/${GITHUB_USER}/${MY_PN}/${PV}/README.md -> ${MY_PNV}-README.md
+ https://raw.githubusercontent.com/${GITHUB_USER}/${MY_PN}/${PV}/CHANGES.md -> ${MY_PNV}-CHANGES.md
+"
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.7"
+DEPEND=">=virtual/jdk-1.7"
+
+RESTRICT="test"
+
+src_unpack() {
+ mkdir -p "${S}" || die "Can't mkdir ${S}"
+ cd "${S}" || die "Can't enter ${S}"
+ for file in ${A}; do
+ einfo "Copying ${file}"
+ cp "${DISTDIR}/${file}" "${S}/" || die "Can't copy ${file}"
+ done
+}
+
+src_prepare() {
+ einfo "Copying boot shell-script"
+ cp "${FILESDIR}/boot" "${S}/" || die "Can't copy boot"
+
+ for file in "README.md" "CHANGES.md"; do
+ einfo "Renaming ${MY_PNV}-${file} to ${file}"
+ mv "${S}/${MY_PNV}-${file}" "${S}/${file}" || die "Can't rename ${MY_PNV}-${file} to ${file}"
+ done
+
+ java-pkg_init_paths_
+
+ sed -i "s|@@JAVA_PKG_SHAREPATH@@|${JAVA_PKG_SHAREPATH}|g" "${S}/boot" || die "Can't patch JAVA_PKG_SHAREPATH path in boot"
+ sed -i "s|@@JAVA_PKG_JARDEST@@|${JAVA_PKG_JARDEST}|g" "${S}/boot" || die "Can't patch JAVA_PKG_JARDEST path in boot"
+ sed -i "s|@@PN@@|${PN}|g" "${S}/boot" || die "Can't patch PN in boot"
+
+ default
+}
+
+src_compile() { :; }
+
+src_install() {
+ dobin "${S}/boot"
+ dodoc "${S}/README.md"
+ dodoc "${S}/CHANGES.md"
+
+ java-pkg_newjar "${S}/${MY_PNV}.jar"
+}
+
+pkg_postinst() {
+ einfo "This package will still download a whole lot of its own runtime"
+ einfo "dependencies the first time you run it."
+ einfo ""
+ einfo "This currently can't be helped and is expected behaviour for a"
+ einfo "java based development toolkit"
+ einfo ""
+ einfo "You may also need to nuke ~/.boot/boot.properties to get the"
+ einfo "updated mechanics, and for boot --version to behave correctly"
+ einfo "due to upstreams per-user/per-project version-locking mechanisms"
+}