summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/toml-parser/toml-parser-1.3.0.0.ebuild')
-rw-r--r--dev-haskell/toml-parser/toml-parser-1.3.0.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-haskell/toml-parser/toml-parser-1.3.0.0.ebuild b/dev-haskell/toml-parser/toml-parser-1.3.0.0.ebuild
new file mode 100644
index 000000000000..f267f824e12f
--- /dev/null
+++ b/dev-haskell/toml-parser/toml-parser-1.3.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # test-suite
+inherit haskell-cabal
+
+DESCRIPTION="TOML 1.0.0 parser"
+HOMEPAGE="https://hackage.haskell.org/package/toml-parser"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RESTRICT=test # build log: 'ghc: could not execute: markdown-unlit'
+
+RDEPEND=">=dev-haskell/prettyprinter-1.7:=[profile?] <dev-haskell/prettyprinter-1.8:=[profile?]
+ >=dev-haskell/text-0.2:=[profile?] <dev-haskell/text-3:=[profile?]
+ >=dev-lang/ghc-8.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/alex-3.2
+ >=dev-haskell/cabal-3.2.0.0
+ >=dev-haskell/happy-1.19
+"
+# test? ( || ( ( >=dev-haskell/hspec-2.10 <dev-haskell/hspec-2.11 )
+# ( >=dev-haskell/hspec-2.11 <dev-haskell/hspec-2.12 ) ) )
+#"