summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet/notify-sharp/notify-sharp-0.4.0_pre20090305.ebuild')
-rw-r--r--dev-dotnet/notify-sharp/notify-sharp-0.4.0_pre20090305.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-dotnet/notify-sharp/notify-sharp-0.4.0_pre20090305.ebuild b/dev-dotnet/notify-sharp/notify-sharp-0.4.0_pre20090305.ebuild
new file mode 100644
index 000000000000..ae33c3b95e44
--- /dev/null
+++ b/dev-dotnet/notify-sharp/notify-sharp-0.4.0_pre20090305.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils mono
+
+MY_P=${PN}-${PV#*_pre}
+
+DESCRIPTION="a C# client implementation for Desktop Notifications"
+HOMEPAGE="http://www.ndesk.org/NotifySharp"
+SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="doc"
+
+RDEPEND=">=dev-lang/mono-1.1.13
+ >=dev-dotnet/gtk-sharp-2.10.1
+ >=dev-dotnet/dbus-sharp-0.6
+ >=dev-dotnet/dbus-sharp-glib-0.4
+ >=x11-libs/libnotify-0.4.5"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.4.0_pre20080912-control-docs.patch" \
+ "${FILESDIR}/${P}-dbus-sharp.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable doc docs)
+}