summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/cpdf')
-rw-r--r--app-text/cpdf/Manifest1
-rw-r--r--app-text/cpdf/cpdf-2.7.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-text/cpdf/Manifest b/app-text/cpdf/Manifest
index 90af51fd9036..fd1e3a4d9569 100644
--- a/app-text/cpdf/Manifest
+++ b/app-text/cpdf/Manifest
@@ -1 +1,2 @@
DIST cpdf-2.3.1.tar.gz 385720 BLAKE2B fae61c8e62b1c679919512c5fa4c57279e118d7ecc8378b528053a1487731675f47877c6164d92f3770e38db78fd9bcce0635f76f0b2efdf10c775a1e9cf5ed7 SHA512 3f22e76bc6bffe2bcd6b2c27d0aa8dc55b842cf0eee46f23c0f3e23e1a86ac7af4665b48513ae3e2d7d2ae84fc864af3b6c3c92e93d78b7798b801bb9be987a1
+DIST cpdf-2.7.1.tar.gz 1660693 BLAKE2B 71cbb72c06ceacd12adbb97c81a504626273d3c0bc74077936b6693bb397b38c97a2db70703a3da8a7caa49d696ee904992150cba133079408e961ef8c7273a2 SHA512 b23c1c151f095d11b6c3c56766cdc05aa6b12a0e1224880a050f69f67c4d40053f2415ac3f9e54233bf8314ca8bdfccc2c65dd44b0c6d60ae8d7c08b1c411a04
diff --git a/app-text/cpdf/cpdf-2.7.1.ebuild b/app-text/cpdf/cpdf-2.7.1.ebuild
new file mode 100644
index 000000000000..41207a922e79
--- /dev/null
+++ b/app-text/cpdf/cpdf-2.7.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit findlib
+
+DESCRIPTION="A command line tool for manipulating PDF files"
+HOMEPAGE="https://community.coherentpdf.com/ https://github.com/johnwhitington/cpdf-source/"
+SRC_URI="https://github.com/johnwhitington/cpdf-source/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-source-${PV}"
+
+# ISC is only for cpdfxmlm.ml{,i}
+LICENSE="AGPL-3 ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-lang/ocaml-4:=[ocamlopt]
+ ~dev-ml/camlpdf-${PV}:="
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ # parallel make issues
+ emake -j1
+}
+
+src_install() {
+ findlib_src_install
+
+ dobin cpdf
+ dodoc Changes README.md cpdfmanual.pdf
+ doman cpdf.1
+
+ use doc && dodoc -r doc/cpdf/html
+}