summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/bash-2.05b_p13.ebuild2
-rw-r--r--app-shells/bash/bash-3.0_p22.ebuild2
-rw-r--r--app-shells/bash/bash-3.1_p23.ebuild2
-rw-r--r--app-shells/bash/bash-3.2_p57.ebuild2
-rw-r--r--app-shells/bash/bash-4.0_p44.ebuild2
-rw-r--r--app-shells/bash/bash-4.1_p17.ebuild2
-rw-r--r--app-shells/bash/bash-4.2_p53.ebuild2
-rw-r--r--app-shells/bash/bash-4.3_p48-r2.ebuild2
-rw-r--r--app-shells/bash/bash-4.4_p23-r2.ebuild2
-rw-r--r--app-shells/bash/bash-5.0_p18-r2.ebuild2
-rw-r--r--app-shells/bash/bash-5.1_p16-r13.ebuild2
11 files changed, 11 insertions, 11 deletions
diff --git a/app-shells/bash/bash-2.05b_p13.ebuild b/app-shells/bash/bash-2.05b_p13.ebuild
index 332d2e91577c..6836c71ee4d0 100644
--- a/app-shells/bash/bash-2.05b_p13.ebuild
+++ b/app-shells/bash/bash-2.05b_p13.ebuild
@@ -103,7 +103,7 @@ src_configure() {
# bash 5.3 drops unprototyped functions, earlier versions are
# incompatible with C23.
- append-cflags -std=gnu17
+ append-cflags $(test-flags-CC -std=gnu17)
local myconf=(
--with-installed-readline=.
diff --git a/app-shells/bash/bash-3.0_p22.ebuild b/app-shells/bash/bash-3.0_p22.ebuild
index 432241662256..6ea72c071984 100644
--- a/app-shells/bash/bash-3.0_p22.ebuild
+++ b/app-shells/bash/bash-3.0_p22.ebuild
@@ -108,7 +108,7 @@ src_configure() {
# bash 5.3 drops unprototyped functions, earlier versions are
# incompatible with C23.
- append-cflags -std=gnu17
+ append-cflags $(test-flags-CC -std=gnu17)
local myconf=(
--with-installed-readline=.
diff --git a/app-shells/bash/bash-3.1_p23.ebuild b/app-shells/bash/bash-3.1_p23.ebuild
index 7e9fb5554451..66fae17e010a 100644
--- a/app-shells/bash/bash-3.1_p23.ebuild
+++ b/app-shells/bash/bash-3.1_p23.ebuild
@@ -103,7 +103,7 @@ src_configure() {
# bash 5.3 drops unprototyped functions, earlier versions are
# incompatible with C23.
- append-cflags -std=gnu17
+ append-cflags $(test-flags-CC -std=gnu17)
local myconf=(
--with-installed-readline=.
diff --git a/app-shells/bash/bash-3.2_p57.ebuild b/app-shells/bash/bash-3.2_p57.ebuild
index c00b1b641c4a..790bcdb42b27 100644
--- a/app-shells/bash/bash-3.2_p57.ebuild
+++ b/app-shells/bash/bash-3.2_p57.ebuild
@@ -105,7 +105,7 @@ src_configure() {
# bash 5.3 drops unprototyped functions, earlier versions are
# incompatible with C23.
- append-cflags -std=gnu17
+ append-cflags $(test-flags-CC -std=gnu17)
local myconf=(
--with-installed-readline=.
diff --git a/app-shells/bash/bash-4.0_p44.ebuild b/app-shells/bash/bash-4.0_p44.ebuild
index 62b57fd03b03..83095fd10267 100644
--- a/app-shells/bash/bash-4.0_p44.ebuild
+++ b/app-shells/bash/bash-4.0_p44.ebuild
@@ -99,7 +99,7 @@ src_prepare() {
src_configure() {
# bash 5.3 drops unprototyped functions, earlier versions are
# incompatible with C23.
- append-cflags -std=gnu17
+ append-cflags $(test-flags-CC -std=gnu17)
local myconf=(
--with-installed-readline=.
diff --git a/app-shells/bash/bash-4.1_p17.ebuild b/app-shells/bash/bash-4.1_p17.ebuild
index e17891fc9cb2..056fcbfee8cb 100644
--- a/app-shells/bash/bash-4.1_p17.ebuild
+++ b/app-shells/bash/bash-4.1_p17.ebuild
@@ -94,7 +94,7 @@ src_prepare() {
src_configure() {
# bash 5.3 drops unprototyped functions, earlier versions are
# incompatible with C23.
- append-cflags -std=gnu17
+ append-cflags $(test-flags-CC -std=gnu17)
local myconf=(
--with-installed-readline=.
diff --git a/app-shells/bash/bash-4.2_p53.ebuild b/app-shells/bash/bash-4.2_p53.ebuild
index 9736efa4fdb6..9189dd542110 100644
--- a/app-shells/bash/bash-4.2_p53.ebuild
+++ b/app-shells/bash/bash-4.2_p53.ebuild
@@ -106,7 +106,7 @@ src_configure() {
# bash 5.3 drops unprototyped functions, earlier versions are
# incompatible with C23.
- append-cflags -std=gnu17
+ append-cflags $(test-flags-CC -std=gnu17)
local myconf=(
--with-installed-readline=.
diff --git a/app-shells/bash/bash-4.3_p48-r2.ebuild b/app-shells/bash/bash-4.3_p48-r2.ebuild
index e5cd244c3acf..d1bd7188d32a 100644
--- a/app-shells/bash/bash-4.3_p48-r2.ebuild
+++ b/app-shells/bash/bash-4.3_p48-r2.ebuild
@@ -115,7 +115,7 @@ src_configure() {
# bash 5.3 drops unprototyped functions, earlier versions are
# incompatible with C23.
- append-cflags -std=gnu17
+ append-cflags $(test-flags-CC -std=gnu17)
local myconf=(
--docdir='$(datarootdir)'/doc/${PF}
diff --git a/app-shells/bash/bash-4.4_p23-r2.ebuild b/app-shells/bash/bash-4.4_p23-r2.ebuild
index 4c094621f6b4..a00a3d5f57b9 100644
--- a/app-shells/bash/bash-4.4_p23-r2.ebuild
+++ b/app-shells/bash/bash-4.4_p23-r2.ebuild
@@ -126,7 +126,7 @@ src_configure() {
# bash 5.3 drops unprototyped functions, earlier versions are
# incompatible with C23.
- append-cflags -std=gnu17
+ append-cflags $(test-flags-CC -std=gnu17)
local myconf=(
--disable-profiling
diff --git a/app-shells/bash/bash-5.0_p18-r2.ebuild b/app-shells/bash/bash-5.0_p18-r2.ebuild
index 9500f0a8c941..8b51f3570ada 100644
--- a/app-shells/bash/bash-5.0_p18-r2.ebuild
+++ b/app-shells/bash/bash-5.0_p18-r2.ebuild
@@ -130,7 +130,7 @@ src_configure() {
# bash 5.3 drops unprototyped functions, earlier versions are
# incompatible with C23.
- append-cflags -std=gnu17
+ append-cflags $(test-flags-CC -std=gnu17)
local myconf=(
--disable-profiling
diff --git a/app-shells/bash/bash-5.1_p16-r13.ebuild b/app-shells/bash/bash-5.1_p16-r13.ebuild
index ddf5fd454024..c760b90a57da 100644
--- a/app-shells/bash/bash-5.1_p16-r13.ebuild
+++ b/app-shells/bash/bash-5.1_p16-r13.ebuild
@@ -175,7 +175,7 @@ src_configure() {
# bash 5.3 drops unprototyped functions, earlier versions are
# incompatible with C23.
- append-cflags -std=gnu17
+ append-cflags $(test-flags-CC -std=gnu17)
myconf=(
--disable-profiling