summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-forensics/zzuf')
-rw-r--r--app-forensics/zzuf/files/zzuf-0.15_autoconf-musl.patch24
-rw-r--r--app-forensics/zzuf/zzuf-0.15_p20190208.ebuild4
2 files changed, 28 insertions, 0 deletions
diff --git a/app-forensics/zzuf/files/zzuf-0.15_autoconf-musl.patch b/app-forensics/zzuf/files/zzuf-0.15_autoconf-musl.patch
new file mode 100644
index 000000000000..0a56a968e84d
--- /dev/null
+++ b/app-forensics/zzuf/files/zzuf-0.15_autoconf-musl.patch
@@ -0,0 +1,24 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -6,6 +6,8 @@
+
+ AC_PREREQ(2.50)
+
++AC_USE_SYSTEM_EXTENSIONS
++
+ AM_PROG_CC_C_O
+ AC_PROG_CPP
+ AC_PROG_LIBTOOL
+@@ -172,6 +174,12 @@
+ AC_TRY_COMPILE(
+ [#define _LARGEFILE64_SOURCE
+ #define _LARGEFILE_SOURCE
++ #include <stdio.h>],
++ [fpos64_t x; long long int y = x.__lldata;],
++ [ac_v_fpos64_t="(x).__lldata"])
++AC_TRY_COMPILE(
++ [#define _LARGEFILE64_SOURCE
++ #define _LARGEFILE_SOURCE
+ #include <stdio.h>],
+ [fpos64_t x; long long int y = (long long int)x;],
+ [ac_v_fpos64_t="(x)"])
diff --git a/app-forensics/zzuf/zzuf-0.15_p20190208.ebuild b/app-forensics/zzuf/zzuf-0.15_p20190208.ebuild
index 6b18d9b65c4d..e20563debda6 100644
--- a/app-forensics/zzuf/zzuf-0.15_p20190208.ebuild
+++ b/app-forensics/zzuf/zzuf-0.15_p20190208.ebuild
@@ -20,6 +20,10 @@ RESTRICT="test"
DOCS=( AUTHORS COPYING TODO )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.15_autoconf-musl.patch
+)
+
S="${WORKDIR}"/${PN}-${EGIT_COMMIT}
src_prepare() {