summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/fsharp-mode/fsharp-mode-1.10_p20211229.ebuild')
-rw-r--r--app-emacs/fsharp-mode/fsharp-mode-1.10_p20211229.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/app-emacs/fsharp-mode/fsharp-mode-1.10_p20211229.ebuild b/app-emacs/fsharp-mode/fsharp-mode-1.10_p20211229.ebuild
index f5407ecb598a..38c255fda39b 100644
--- a/app-emacs/fsharp-mode/fsharp-mode-1.10_p20211229.ebuild
+++ b/app-emacs/fsharp-mode/fsharp-mode-1.10_p20211229.ebuild
@@ -16,11 +16,19 @@ S="${WORKDIR}"/emacs-${PN}-${H}
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RESTRICT="test" # requires Cask
+IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="app-emacs/s"
-BDEPEND="${RDEPEND}"
+BDEPEND="
+ ${RDEPEND}
+ test? ( app-emacs/buttercup )
+"
DOCS=( CHANGELOG.md README.org )
-ELISP_REMOVE="eglot-fsharp.el"
+ELISP_REMOVE="eglot-fsharp.el test/integration-tests.el"
SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ buttercup -L . -L test --traceback full || die
+}