summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/mirage2iso/mirage2iso-0.4.2-r1.ebuild (renamed from app-cdr/mirage2iso/mirage2iso-0.4.2.ebuild)25
1 files changed, 10 insertions, 15 deletions
diff --git a/app-cdr/mirage2iso/mirage2iso-0.4.2.ebuild b/app-cdr/mirage2iso/mirage2iso-0.4.2-r1.ebuild
index c1efb10c0087..86120322a7c6 100644
--- a/app-cdr/mirage2iso/mirage2iso-0.4.2.ebuild
+++ b/app-cdr/mirage2iso/mirage2iso-0.4.2-r1.ebuild
@@ -1,33 +1,28 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
DESCRIPTION="CD/DVD image converter using libmirage"
HOMEPAGE="https://github.com/mgorny/mirage2iso/"
-SRC_URI="https://github.com/mgorny/${PN}/releases/download/v${PV}/${P}.tar.xz
+SRC_URI="
+ https://github.com/mgorny/${PN}/releases/download/v${PV}/${P}.tar.xz
test? ( https://github.com/mgorny/${PN}/releases/download/v${PV}/${P}-tests.tar.xz )"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="pinentry test"
+RESTRICT="!test? ( test )"
-COMMON_DEPEND=">=dev-libs/libmirage-2.0.0:0=
+DEPEND="
+ >=dev-libs/libmirage-2.0.0:0=
dev-libs/glib:2=
pinentry? ( dev-libs/libassuan:0= )"
-DEPEND="${COMMON_DEPEND}
- app-arch/xz-utils
- virtual/pkgconfig"
-RDEPEND="${COMMON_DEPEND}
+RDEPEND="${DEPEND}
pinentry? ( app-crypt/pinentry )"
-
-RESTRICT="!test? ( test )"
+BDEPEND="virtual/pkgconfig"
src_configure() {
- local myconf=(
- $(use_with pinentry libassuan)
- )
-
- econf "${myconf[@]}"
+ econf $(use_with pinentry libassuan)
}